Unmatched desktop builds

Mine resides in a QB ONE case.
I stick to FUSDK to benefit from latest updates.
The lack of any repository is a bit painful of course.
But the famous scummvm compiles pretty well (after compiling sdl2 as well which is also simple)
See it below running the FREE (and awesome) game Lure of the Temptress.
Even audio via HDMI worked out of the box (with a radeon 9450 that however runs unstable and crashes after a while, replacing it with a RX550 soon).

2 Likes


rx550 + 970evo plus
no project as for now, just playing around :grinning:

4 Likes

I just finished my build:


What you’re looking at is:

  • HiFive Unmatched (of course :slight_smile: )
  • BC1-Mini benchtable
  • Corsair SFX SF450 PSU (mounted beneath the baseplate, barely visible)
  • Samsung 970 Evo Plus 250 GB SSD
  • ICY Box IB-M2HS-70 heatsink for the SSD
  • HIS 7750 iCooler 1GB GPU, which I’ve removed now, it’s not even listed in lspci, so I think either the card is wrong, or it needs too much power and the board can’t deliver
  • Asus Xonar U7 USB audio adapter
  • I also have a Icy Dock MB861U31-1M2B USB-NVME adapter (not on the picture), just in case i need to change something on the NVME and i can’t do it with the Unmatched, my other PC’s don’t gave nvme :slight_smile:

It boots ok with the provided sdcard. I noticed it keeps trying to start the X server, which fails because there’s no GPU. Any idea how to stop that?

3 Likes

Never mind my question about the xserver, it’s: systemctl stop xserver-nodm.service

The first time I did that it crashed the machine, only a hard power-off worked. Now I tried it a second time a it works as I expected.

Some old reviews of your card suggest that the power consumption is around 40-50W, like this one that says 43W specifically.

A standard PCIe slot is supposed to be able to provide up to 75W. So unless that is different on the Hifive Unmatched, power “shouldn’t” be the issue. Do you have another computer you can test the graphics card in?

I just put it into a 1U rack

4 Likes

Thanks for finding out the power consumption of the card @cavemanol, it isn’t very excessive indeed. I don’t have an other PC around to test with, but I might be able to do that next monday. It’s an old card, the fans are very noisy, so it might just as well be broken.

My first stumbling and bumbling youtube video (ever). Some co-workers interested in this board pushed me to do one. :grinning: I have crude audio/video equipment, a noisy environment, and do not have a radio voice…but it’s done.

The build is running great now though. All the time wasted learning Shotcut and Audacity I can now spend on trying to compile some dev tools that are missing in this ecosystem. :slight_smile:

5 Likes

this was a great video!

was the graphics performance worse on ubuntu vs openembedded?

im on a 4k monitor and openembedded is a bit sluggish even though i have a 4GB rx 550… i wonder if its the same issue…

(unfortunately, i havent been able to boot get ubuntu booting at all)

Thanks for the kind words. I honestly went straight to that Ubuntu image. I haven’t actually touched the card that came with the Unmatched.

My dual monitors are 1920x1200. I have Displayport out → DVI adapter → KVM for the main monitor.

My secondary monitor is using the VGA out of the sapphire directly to the port on the monitor (I have to switch inputs manually on my 2nd monitor).

I’m not really a benchmark kind of guy, but maybe I should look around and see what’s available to run. Maybe it’s “radeon” vs “amdgpu” after all, but I guess could be CPU throttling? I’m not sure of the nuances between X and Wayland as far as leveraging the GPU.

Sure, moving around in the UI is a bit sluggish, but I’m so eager to find out what is or is not available in apt that I haven’t given the graphics driver a second thought today. It’d be nice to see what’s going on and make things better there, but it’s not crippling my explorations of other things.

I really think the only seriously annoying perf issue I’m seeing is the one in Epiphany…which I’m pretty sure is the JS engine (not V8).

yes, i have no scientific evidence, but it seems to me the ui is not accelerated, and the js engine in epiphany seems to be missing some perofrmance (not using jit?)

other than that id say performance seems pretty acceptable

and ill try ubuntu again, glad someone was able to get it working on the first try!

and maybe sometime ill try to make a video too ^^

here is my desktop

  • CASE: JONSBO T8
  • POWER SUPPLY: Corsair SF750
  • GPU: MSI Radeon RX 550 AERO ITX 4G
  • STORAGE: Samsung 970 EVO Plus 500GB
  • CPU FAN: AINEX OMEGA TYPHOON
  • MONITOR: LG 32UD99-W 4K

i pick this case because i dont like a computer i cant throw…

built retroarch and run some snes demoscene

hopefully next i could get obj-c / gnustep building…

2 Likes

I still haven’t tested the card, but i did test a different card (an old/passive cooled nvidia NVS300), and it worked. It showed me the console login and (of course) it showed up in lspci. It still tells me nothing about the other card, but it does prove the unmatched is ok.

Great looking build and good to see retroarch running snes games, I installed the one from the ubuntu repos and am currently getting an error stating “*** longjmp causes uninitialized stack frame ***: terminated”. I’ll check later for the actual wording, but i get that error when launching both snes and n64 games. Gba/gb games seems to run just fine.

Glad to hear your board is fine.

yea, it took all night to build all the emulator cores, ive tested genesis/megadrive and snes, i wanted to try some psx/n64 soon

only a few of the cores couldnt build (such as dosbox and ffmpeg)

they seem to all run pretty well (though not while running a compilation on all cores concurently)

My first run of the unmatched (still with the Radeon which I replaced with an RX550 by now).
Hooked up to a Nexdock2 to have the mouse+keyboard and big screen for the ssh and research work (still).


Thank you SiFive for this step!

Small updates in a second video.

I have already made the switch to KDE in real time, though this 2nd video, and probably a third one eventually, are all footage of installing and playing around programming while on the Gnome desktop from the original install.

I’m finding I prefer KDE on the unmatched, and I went with kde-full to see what all came along and how it worked. But man…if you thought epiphany struggled, it looks like a champ compared to how poor Konqueror is doing on the Unmatched. Not just speed, but Konqueror is not rendering pages with near the fidelity that epiphany was.

2 Likes

I suspect there is no functional JavaScript compiler for RISCV. At least chromium doesn’t have a RISCV backend yet and a browser nowadays is a big compiler!

V8 is not fully baked on RISCV and V8 beats WebKitGTK, but yes, it would be interesting to know if WebKitGTK on RISCV has shortcomings even compared to WebKitGTK on ARM or on Intel.

I am not up on the latest intricacies of javascript engine since I’m mostly backend development and don’t use Node. I have watched some videos on the RISCV work on a port, but don’t recall the exact status.

I ran some trivial node programs on the Unmatched already to test this version of node, but I haven’t documented that yet.