Help! You bricked my ARTY!


I just downloaded the freedom-e310-arty-1-0.mcs file and followed instructions in the SiFive-E310-arty-gettingstarted-v1.0.pdf file. At first, it appeared to work, i.e. Vivado reported successfully adding the freedom-e310-arty-1-0.mcs using “Add Configuraton Memory Device” , successfully erasing, then successfully programming; “DONE” LED went green, and after pressing the “PROG” button, the “DONE” LED momentarily went off, the yellow LED next to the J10 blipped shortly, and then the “DONE” LED again lit green. I thought, “Great, everything seemed to work!”. However, after setting up a TeraTerm terminal and resetting as instructed, both LED4 and LED6 went green, and no activity occurred in the Terminial. I next tried resetting, going through all of the available BAUD rates, but no activity on the Terminal. Since nothing worked as published, I decided to reinstall the origninal demo programm which ran with the ARTY out of the box. Attempting to do so, I found that the ARTY is no longer recognized by Vivado:

The ARTY was working perfectly before following the instructions in the PDF.

Does anyone know how to revive a bricked ARTY?


Thanks for trying it out!

It’s confusing, but the MCS file that we posted on the web no longer includes the SW program that prints to the Terminal. The instructions explain how to load it with the debugger, so out of the box you wouldn’t see anything on the terminal. We’ve realized this is confusing and not everyone has a debugger, so, we’re going to create an updated MCS image with the SW pre-loaded. For now, the fact that you didn’t see anything on the terminal is to be expected.

As for the other problem, I’ve never seen that before… I assume you’ve already tried the standard “unplug and plug it back in again”, restart Vivado, etc.

Yes, indeed I have. I have tried different USB ports, different Vivado versions, using SDK, and also the TCL shell: nothing will connect to the ARTY.

100 bucks down the drain?

Have you tried restarting your computer? For me, the Vivado tools sometimes get into a bad state that can be fixed by completely restarting my computer.

Hi Richard,

Thanks, and yes, I have tried rebooting. In the meantime I have connected the ARTY to another machine with a fresh installation of Vivado, and it is ok. Apparantly the SiFive procedure has broken my cable drivers. I think that if I re-install them on the problem machine it should work again.

@ Megan: if I should not expect anything from the terminal, what should I expect? Is it a demo that does nothing?

Thanks and regards,

I just uploaded a new version of the MCS file to our site with the demo_gpio program preloaded. This version is named freedom-e310-arty-1-0-1.mcs, and it should match what the Getting Started Guide describes (i.e. an LED should light up and a message should get printed over UART).

Sorry about all the confusion this caused.

Hi Richard,

Ok, I will try it after I get Vivado working again. Re-installing the cable drivers did not help, so I will now try re-installing Vivado. Hopefully, that will work.

Thanks and regards,

Hi all,

Re-installing Vivado also did not help. I was at last able to solve the problem after comparing the USB devices appearing in the device managers of the two machines. In the problem machine I found a Digilent USB device which did not appear in the working machine. After performing a driver update on the “Digilent” device, it was replaced by a Microsoft driver and no longer appeard as “Digilent”. After that, Vivado again recognized my ARTY.

I next downloaded the new file named named freedom-e310-arty-1-0-1.mcs and repeated the instructions in the PDF. I noticed that this time there were 4 steps shown while programming instead of 2, apparantly due to the added program, and again everything appeared to work, but I still get no activity in the terminal.

I am runnung Vivado on Windows7. Can somebody verify the .mcs file is working for them?

Thanks and regards,

Hi Richard,

It appears to me that the new file freedom-e310-arty-1-0-1.mcs is not as advertised. I found an older .mcs file which I downloaded back in Septermber (freedom-e300-arty-0-1.mcs) and followed the procedure using that file. It works fine, giving me 4 bright red flashing LEDs which I can control via both pushbutton and slide switched, and the nice welcome grapfic in the terminal.

I can now go on to better things, but I think you should recheck the latest published .mcs file.


Hi Donnie,

I independently downloaded and tested the new MCS file. It does print the message to the screen but we do need to do some debugging on the Buttons & LED code (the message helpfully lets us know that we’re getting an unhanded exception in our timer interrupt). I’m using Ubuntu however, haven’t tried it on Windows 7. What Terminal utility do you use for Windows?

You’re correct that the old image “works better” out of the box, but it’s not really compatible with the new SDK if you want to write and upload new SW programs (which we hope is the goal of someone using the Dev Kit).

Hi Megan,

I am using TeraTerm as a utility.

I understand the need for the new file, but using the old file I could at least confirm that may basic setup is working. I suppose that using Windows as a platform is probably a minority choice, but I guess that makes my testing all the more useful for picking up bugs that only occur in Windows, like perhaps this one?

Best regards,

Indeed! Thanks for reporting your experience. We’ll post when we’ve fixed the demo program to blink the LEDs as expected.

I thought I had recreated your driver issue (got similar symptoms that the board was no longer recognized by Vivado) but it turns out that I had mis-connected power and ground on my debugger cables. I don’t think that was your issue, but in case someone else is reading this thread is afraid they’ve bricked their Arty, it’s one more thing to check.