Arty A7-35T with Getting Started MCS file: NO SERIAL OUTPUT


#1

I’ve followed the getting started guide, I followed the guide created the mcs file and programmed the FPGA with Vivado successfully. No matter what I try, I can not get the Sifive logo in the default program to print to the terminal, it is always blank. I’ve tried Linux screen command, double checked the baud rate 115200, no parity, 1 stop bit, cs8, hardware flow control off. I’ve also tried the same with minicom. Nothing will show in the terminal. When I open the serial port and i type buttons, I can see a LED beside the micro-b usb connector on the board blink whenever I press a key on the keyboard. Hitting reset should print the sifive logo out in the terminal, but I never get it. Help please!

Note: The only thing that I had to change from getting started guide is the part with programming with vivado. It says

[Labtools 27-3291] Flash Programming Unsuccessful. Part selected mt25ql128, but part s25fl128sxxxxxx0 detected.

I change the part to the detected one and it programs fine, but no serial output.


#2

I also tried the Arudino IDE to upload the Blink program and got this

Sketch uses 6816 bytes (0%) of program storage space. Maximum is 8388608 bytes.
Open On-Chip Debugger 0.10.0-dev-g9bab078 (2017-02-02-01:39)
Licensed under GNU GPL v2
For bug reports, read
	http://openocd.org/doc/doxygen/bugs.html
adapter speed: 10000 kHz
Info : auto-selecting first available session transport "jtag". To override use 'transport select <transport>'.
Info : ftdi: if you experience problems at higher adapter clocks, try the command "ftdi_tdo_sample_edge falling"
Info : clock speed 10000 kHz
Info : JTAG tap: riscv.cpu tap/device found: 0x20000913 (mfg: 0x489 (<unknown>), part: 0x0000, ver: 0x2)
Warn : JTAG tap: riscv.cpu       UNEXPECTED: 0x20000913 (mfg: 0x489 (<unknown>), part: 0x0000, ver: 0x2)
Error: JTAG tap: riscv.cpu  expected 1 of 1: 0x10e31913 (mfg: 0x489 (<unknown>), part: 0x0e31, ver: 0x1)
Error: Trying to use configured scan chain anyway...
Warn : Bypassing JTAG setup events due to errors
Error: Unsupported DTM version 1. (dtmcontrol=0x5071)
Error: Target not examined yet

the selected serial port 
 does not exist or your board is not connected

#3

Double checked wiring, it is correct. Still no output


#4

maybe u can try some change on SW3,. It’s said that Arduino’s UART may be not the same UART port of freedom-e310 soft SoC and change SW3 can alternate the onboard uart output between freedom-e310 and Arduino. The explainion can be located in ArtyShell.scala, which can be found in the repo freedom/fpga-shells/src/main/scala/shell/xilinx/ArtyShell.scala


(Erik Danie) #5

Hello,

You should make sure the hardware and bitfile match up, especially given that error message. Where did you get the bitstream from? We do not produce Arty35T bitstreams in any core tarballs anymore (since the hardware was just too small to fit much, we moved up to the arty100T). You can generate an E300 on Arty35t from the freedom repo, but if you want to use a different core you may need to synthesize the verilog separately.


#6

Yes I used the E300 bitstream from the freedom repo. I recently used the x300 rocket bitstream from Hex-Five, and still cannot get any serial output from their demo. I may have to upgrade to the 100T, but that will be another $250. I didn’t realize the 35T was phased out when I bought it, bummer. I will have a High Five rev. B in possession soon, I think the crowd fund should ship out Feb 7th.


(Erik Danie) #7

Okay, I am not too familiar with the arduino IDE’s error messages and how it connects to the serial port. Can you try directly opening a serial port with screen, as outlined in page 10 of the user guide and see if you get output that way? You may need to hit the board’s RST button to cause the serial output to print again.