Anyone receive their Unmatched?

Blocked by US entity list …

@ rockrush
buy it in the name of the company. they can’t sell it to personal user from chinese mainland .
At the same time, send a mail taunting their export rule bitterly

Received my board today from Mouser. Shipped yesterday. Received email notification yesterday of shipment. Placed my order with Mouser in Jan. I looked at crowdsupply but that reminded me of Kickstarter and Mouser seemed more solid trustworthy place to order from. Did not know that Mouser owns CrowdSupply.

Just need my Samsung 970 Evo plus NVMe drive to arrive.

1 Like

Until yesterday, 10 June, they said they would ship by the 11th. I just saw that the shipping date has been updated to 30 June. Either I’ll get a shipping notification later today, or I’ll have to continue to be patient.

Addendum: Around 10 a.m. local time, I received an email from Crowd Supply. “Your Crowd Supply order (123456) has shipped!”

2 Likes

Ordered (CS): 5/22
Tracking # EST delivery (USA): 6/15

Seems they have worked the backlog pretty good.

2 Likes

Yes. Received my Unmatched and unboxed it this morning. Nice little board and I really like the black PCB. I wish they had used a slightly different size CPU heatsink fan as it will be hard to find an alternate quiet Noctua like fan.

I ordered a Samsung 970 EVO plus 2 TB and Samsung 2 TB SSD from Amazon at 10PM last night and it was at my doorstep by 10am. Impressive. Also received the Intel woof module a couple days ago.

I see neither the RTC nor NVMe boot are supported yet. Hope and fully expect the NVMe boot gets fixed very quickly.

1 Like

I received my Unmatched and for starters mounted it in an InWin Chopin Mini-ITX HTPC case w/ 150W supply. Boots from SD card as expected.

I’d like to avoid a GPU entirely. What are my prospects for running xrdp under Ubuntu? Thanks.

I’ve ordered via mouser (almost 2 weeks ago) with a pro-forma invoice. Somehow they struggle to find my payment (even though i even payed twice in an attempt to get things going again), and since they ship only after the payment has been received, i didn’t receive my unmatched yet :frowning:

xrdp should be able to run without any graphics hardware, I’ve done that on a headless server as a honeypot connected to the internet :slight_smile: . If you need to run something that needs an X server to talk to you can try xvfb which emulates a full X server without any physical displays or input devices attached to it.

hi,
I received my "unmatched’ a week ago.
It boots from the sdCard that came with it :slight_smile:
I added NVMe storage and a used Radeon HD 6450. The graphics card is used successfully.
I can build the openembedded image (took a few hours on first attempt) and boot it.
I can boot the ubuntu image found here: https://cdimage.ubuntu.com/releases/21.04/release/ubuntu-21.04-preinstalled-server-riscv64+unmatched.img.xz
However, I failed to install this on the NVMe card. Looks like I did not correctly propagate the “root=/dev/nvme0n1p1” information into the boot args, or something such.

I tried to “recycle” the steps listed in debian wiki about the hifive unleashed
https://wiki.debian.org/InstallingDebianOn/SiFive/HiFiveUnleashed
but got stuck on the first step (multistrap). I’m sure there are better ways already to install Debian on the unmatched.

Cheers,
Erich

1 Like

I cheated and still use the sd card for booting, but set the root partition to the NVMe drive. Mount the SD card’s /boot partition (/dev/mmcblk0p3), edit the extlinux/extlinux.conf file to use your NVMe drive for root. Mine looks like this:

menu title Cubo-R1 Boot Options
timeout 100

default debian

label debian
   menu label debian
   kernel /Image.gz
   fdt /hifive-unmatched-a00.dtb
   append earlyprintk rw root=/dev/nvme0n1p4 rootfstype=ext4 rootwait console=ttySIF0,115200 earlycon

label install
   menu label install
   kernel /Image.gz
   fdt /hifive-unmatched-a00.dtb
   append console=ttySIF0,115200 earlycon loglevel=0 earlyprintk
   initrd /initrd-install.gz

label OpenEmbedded-SiFive-HiFive-Unmatched
   kernel /Image.gz
   fdt /hifive-unmatched-a00.dtb
   append root=/dev/mmcblk0p4 rootfstype=ext4 rootwait console=ttySIF0,115200 earlycon loglevel=0

That’s not cheating. That’s the supported method.

Getting u-boot off the SD is no problem. Getting the linux kernel from the SD takes forever, but nothing at all from the NVMe.

2 Likes

It seems my payment with mouser finally worked out, according to my track&trace number I can expect my Unmatched on Thursday :partying_face:

1 Like

Welcome to this small club of owners

2 Likes

Hi,
thanks for pointing this out.

For the records:
When editing /etc/default/u-boot I missed the “root=” part.
Booting then ends in a busybox with “(initrd)” as the prompt.
That’s not too bad after all, I mounted the partition in question and edited the file using good ol’ sed and shell redirections :slight_smile:
Now my system boots Ubuntu 21.04.
Right now I’m installing my favourite GUI now: sway
Off to new adventures,
Erich

1 Like

3D-printed fan mount is better for mounting bigger fan (than my original method, mounting with “a” screw). The problem is, two screws are just “sticked” into gaps of heatsink and screwing/unscrewing fan mounting screw repeatedly can severely damage heatsink.

I tested sirn’s fan mount design (3D-printed with PA11, heat-resistant yet flexible plastic) and working perfectly with both Noctua NF-A4x10 FLX and AINEX CFZ-4010LA (a bit tighter than Noctua but it still fits).

I found Noctua NF-A4x10 FLX (which is supposed to be louder than AINEX CFZ-4010LA [comparing dBA values] but actually, less annoying, even without L.N.A.) has bigger corner holes than the original 25mm fan and AINEX CFZ-4010LA (model I initially replaced with the original fan) so fan mount like sirn’s design (rather than a screw) is practically necessary if you use Noctua fan (not mandatory [you could fill in the screw hole at corner] but far better for stable and tight mounting).

2 Likes

My board (ordered April 26th) just arrived in Germany.
All works so far. Trying to set up the known ubuntu (but my wifi card isnt detected, so I’m waiting for the proper 9260 to arrive. Cheers!

You could also check out other heatsinks. The heatsink on the Unmatched is relatively small, so most “cpu” heatsinks will be way too big. There are endless sizes of heatsinks though, one sold as a VGA heatsink or similar may work. They often have lower profiles (height) too. It appears there is plenty of space around the CPU, if an oversized heatsink was used. The Unmatched has a unique CPU mounting tab I’ve only seen from that one supplier. Adhesive thermal pastes are available, sometimes already on the heatsink, that allow you to glue the new heatsink to the CPU. Then you can use much larger fans at low speed, for low noise. Just a thought.

tldr; Get large heatsink with adhesive, add fan.

I used a spare plastic washer from the M.2 mounting kit supplied with the Unmatched. It fit well in the large Noctua hole.

1 Like

try this