Unmatched First Runs

hello,

first comments after running my freshly received HiFiveUnmatched board with the provided Freedom USDK 2021.03.01 sdcard

The board was completed with a Radeon RX 570 ITX card, a 400 Watts PSU, a Intel 9260 Wireless card, and a not yet tested NVME SDD 250 GB (more later), all mounted in QB One case (nice fit).

the first boot with provided SDCard was ok, logged through provided usb cord, before adding the graphic card today. I already noticed then the quite noisy fan (CPU fan it seems). I’ll check other topics about replacing it later maybe.

After adding the RX570, next boot was ok, after a few seconds (or 1 minute) after the “login” appears on the wired console (PUTTy / windows) ; then the graphic card is activated and present the XFCE screen as expected.

WIFI runs perfectly.
I"ve started to follow topic tuto to install Ubuntu 21, but unzipping the image simply make my SD card FULL, so i’ll use usb stick with prepared image instead (TO DO) to install on my NVME disk.

Now the small problems i’ve seens :

  • Keyboard layout sticks to English whatever the change i applied (FR) in the XFCE settings (no found relevant command in the shell, maybe need specific setup)
  • the clock restarts in 2020 even with a fresh CR1220 battery added on the board, and the date command beeing applied correcly before stopping or rebooting the board.
  • the keyboard(s) (wireless or not, USB) ar usually ending non responsive after some minutes (variable) so i have to disconnect/reconnect it ,
    the wired mouse is ok.

Interestingly, I’m am having the reverse of your keyboard issue. My keyboard doesn’t seem to have any issues with becoming non responsive so far, but my mouse will become non responsive after a variable amount of time. I’ve test 2 different mice (both wired) and have had the same issue with a wired XBox controller as well.

1 Like

No problems at all here with Microsoft Wireless 850 keyboard & mouse set.

1 Like

These tips may help with keyboard configuration.

1 Like

thanks for the tips, i will check that (a lot of /usr/bin and /bin commands are shortcuts to coreutils & util-linux & co (so maybe getting keyboard layout change is more complicated that i thought, maybe needing rebuilding a more complete SD boot image with more tools on it, but it is a good exercise for me to dig into that).
Curiously today the keyboard worked perfectly, no freeze at all … Very strange.
Seeing a quake2 binary, i cannot resist to install required data, copy binary at parent location of data, and launching quake2, that runs nice ! (i never take time to tried that game before, being a Unreal Tournament guy).

Very nice board, really.

There is no RTC clock driver yet as far as I know. The keyboard disconnect problem is noted in the freedom-u-sdk release notes. I never tried to change keyboard layout. Maybe we didn’t build all internationalization support. The board ships with OpenEmbedded which is not a desktop OS replacement. You might want to try a debian, ubuntu, or fedora image.
https://github.com/sifive/freedom-u-sdk/blob/2021.05/ReleaseNotes/2021.05.md

1 Like

Hello, you are right, the problem of keyboard/mouse freeze was listed in the last release note already (i read it quickly but forget this part, sorry!). The date/time is finally updated after UI is loaded (after a while) and WIFI connection is up (NTP server joined ?). I’ll check that.
I m waiting to receive another SD card to install Ubuntu 21, but i will also dig into OpenEmbedded that i’m not familiar with. Thanks,

Thanks, your tips was perfect for the setup of French keyboard as default while installing the Ubuntu 21.04 environment (command line only, for the moment).

1 Like

So I’ve not had any problems with my keyboard becoming non responsive except for one time when it was plugged into a different USB port than the one it has mainly been plugged into. My mouse, on the other hand, has been continuously having occasional issues with becoming non responsive except for the one time it was plugged into the port I’ve mainly been using for my keyboard. I remembered from the product brief that 1 of the USB ports was connected differently compared to the other 3 and I’ve listed that portion of the diagram here.

The schematics also shows this USB hub connecting to 3 USB ports and the single USB port connecting directly to the bridge. However, I have not yet found anything on which of the USB ports is the different port, but the 1 port that is working better for me is the top left port with the motherboard laying flat.

So far, I’ve run the command “libinput debug-events” and watched as the other 3 ports stopped sending event messages after 20 - 40 seconds, while the possibly good USB port kept sending event messages for at least 4 minutes before I stopped paying attention. Additionally, I have noticed that my mouse will sometimes become responsive again on its own. I’ll continue to poke at this over the next few days.

So overall my thoughts are, is it possible that this additional USB hub used for the other 3 USB ports the source of the non responsive behavior that some people are experiencing?

The top left port is USB Bridge and doesn’t go via a hub (as you described). Could you also check if you have this issue on Ubuntu?

i’ll check on which usb port is my keyboard/mouse dongle currently connected (kept unchanged as it is running fine), just to let you know. By the way, i am on Ubuntu 21 for a while with this same port beeing used, with no problem.

So Top Left Usb is the currently connected keyboard/mouse dongle, with no issue ( on Ubuntu 21.04).

I am currently running Ubuntu, I haven’t tested this on any other installs yet.

A long time i’ve shared my progress there.

So i’ve been focused (as some others) to find correct replacement for the cpu fan, and started by using that Fan Adapter from here yet another 25mm to 40mm fan adapter
Result was ok, but i was annoyed to screw something again in the cpu cooler blades (even if original setup is doing that, and getting good result).

So i start playing with that model and FreeCad to add some open box below the fan adapter, to be abble to put it gently onto the cpu cooler metal blade (not really tight fit though), and printed it with a Anycubic Photon S and some temperature resistant resin (HT100).

This was then used with a new cpu fan Noctua NF-A4x20 FLX (that i had to change its 3 pins order to keep 2 pins connected on the original cpu fan connector) and the final result is correct (much less noise, enough cooling).
The resulting setup is :

If you want to see/use the model, it is here : 25mm to 40mm fan adapter for HiFive Unmatched board but it is a first attempt, better model could be done for the same purpose i suppose.

4 Likes

more pictures :



2 Likes

I like your idea a lot! Thanks for sharing. :+1:

What did you use to mount the fan on the adapter? Are those the pins you get with the noctua fan?
I always thought that with loosening the screws of the fan the heat sink will also come loose, but given your solution that doesn’t seem to be the case. Is that true?

hello,

The Heat sink is cliped to the board / socket (i don’t have looked precisely how) so there s no risk by removing the 2 screws (that are “simply” stucking into the heat sink blades on 2 corners. I believe some people have shared on this forum some link to these heat sink part, where you can find document and details on that attaching/clipping method.

I simply put the adapter (+ Noctua fan screwed to it using 4 screws of type M2.5 16 -or 20- plus bolt) onto the cpu heat sink (so no tight fit there), so that the cage simply surround the heat sink blades area enough to maintain all this as expected with space for the air flow and minimum contact with the printed support part.

Using the provided 3 pins cord of the Noctua fan, i had to reverse the red and black wire positions (the yellow wire is not used and will remain outside the 2 pin socket area after insertion) to fit the socket orientation, and that was all :
You can check when you power on the board that the fan is starting to spin (silently :slight_smile: ) to ensure every thing is correct.

Yesterday i compiled a lot (kernel 5.13.9) using 4 cores and the temperature of the CPU was always around 55° C at most ( for 22° in the room), so i believe the setup is ok ;-).