New HiFive Unmatched Board Not Booting

I’m having trouble getting a new HiFive Unmatched board to boot. The SD Card that arrived with it was defective, so I transferred the latest image from Releases · sifive/freedom-u-sdk · GitHub to a fresh micro SD card using rufus. However, it still won’t boot.

I’ve tried the latest image (demo-coreip-xfce4-unmatched-2021.06.00.rootfs.wic.xz), the image it was packaged with (demo-coreip-xfce4-unmatched-2021.03.01.rootfs.wic.xz), and an Ubuntu image ( all with no success.

I’m getting some strange characters on the serial console at baud rate 115200 and an error message of 1 at baud rate 89856 (as the SW manual suggested in Chapter 8, section 1).

The MSEL switches are all set to the proper positions.

Any ideas what might be causing this problem?

Judging from the fact that you’re using Rufus (and the PuTTY windows), I’m guessing that you’re on Windows…

The .xz extension is a compressed archive with the .wic or .img inside it.

Extract the image with WinRAR or 7zip before putting it on the SD Card.

You can watch the first few minutes of my video here for a guide of putting Ubuntu on SD if you’re stuck:

Thanks for your help BinoX. I did get the board to boot eventually with the factory supplied micro SD card. Turns out that I wasn’t patient enough in the beginning and the system would have booted 5 minutes after I pulled the plug. At any rate, there seems to be a real lack of standards/compatibility amongst micro SD cards and their various adapters into modern machines, so choose wisely (randomly?). I will post my recommendations after I do some more testing.

you can insert a ssd and use ssd as rootfs , it will be faster than sd, about 2mins. certainly, u can change cpu freq to 1.2/1.4/1.5 Ghz.

I found the only sdcard that works for me are the SanDisk Ultra A1 cards. Besides the A2 cards not working (as documented), the Samsung EVO cards don’t work either. And I get that same console output you do in your first screenshot (on PuTTY) when I use any of those cards. Since the zero-stage-boot-loader is in ROM, I presume we’re pretty much stuck with poor sdcard support.

even for use ssd mode, sd card is still needed.

Thanks for your help! You are right on about the Samsung EVO - I had a bunch of those that worked great with the Raspberry Pi, but the Unmatched won’t boot them. I went to my local Walmart and bought a couple of Sandisk 32 GB cards just like the ones that came from SiFive and they booted the latest FU-SDK image with no problem.

Very helpful. Thanks!

Thanks Kiutao! Down to 43s from 159s with the rootfs on SSD and not messing with cpu freq.