Cannot boot SD images from SDK 2022.10

I have an Freedom Unmatched board that has an old SD card image built from the Freedom-U SDK version 2021.03.01 using the steps provided at GitHub - sifive/freedom-u-sdk: Freedom U Software Development Kit (FUSDK) , but trying to boot any newer kernels or images copied to the NVMe drive from this build of the SD card fails. This made me think I probably need an updated version of OpenSBI and Das U-Boot, so I build the Freedum-U SDK version 2022.10 from source and imaged a new card. Inserting this card and booting only yields the following output on the serial console:


I also tried the Ubuntu 2022.10 Unmatched image and either got the same output or nothing. Digging around in these forums, I could not find anything that matches this issue. If I use the 2021.03 based SD card and try to boot the kernels from Debian, Ubuntu, or Fedora they tend to crash with an Kernel Oops related to a paging error. Haiku works, FWIW. Any ideas?

There are a number of things that could be going on here. But the simplest explanation is that the SDcard doesn’t work with the unmatched board. There is a known problem that some SDcards work with the board and some don’t. There is also a known problem that when the board powers on the serial port baud rate gets set to a useless value, so error messages emitted by the board itself are unreadable. The SDcard you are using for the fusdk 2022.10, has that ever worked with the board? Maybe put a known working image on it and check if it boots. If not, then it is the sdcard that is the problem.

1 Like

Seems your hunch on card type was correct. I had tried several different types, but they were all Samsung cards (EVO 16G, EVO+ 32G, Pro Endurance 32G) and none worked. Since my old 2021.03 image was on a SanDisk Ultra 32G card, I grabbed some SanDisk Ultra 64G and the FUSDK 2022.10 XFCE4 image worked just fine. In fact, that seems to have fixed most problems. The Ubuntu and Fedora images now also work correctly from my NVMe drive via UEFI and GRUB loaders, which is great. Still getting some strange lockups on CPU/Core/Hart 2 but that seems to be common and I expected this. So seems like Samsung cards are not super compatible with my board.

I will also add that I grabbed a Lanmu 15cm Micro SD card extender (since swapping the card in my was a chore) and that also caused compatibility problems with even the SanDisk cards. It’s also makes it hard to connect the USB-uB console connector. But at least this new OpenSBI and Das U-Boot code seem to have solved most problems in the 2022.10 build.