Where are the factory software to burn to a MicroSD card

Link to original OS image…

Thank you.

Here is the Freedom-U-SDK Github page with all the images. I believe version 2021.03.01 is the original image that came on the sd card, but there are several updated ones too. The image you will want is the “demo-coreip-YYYY-unmatched-XXXX.XX.XX.rootfs.wic.xz” where the YYYY is either xfce4 for graphical or cli for terminal and XXXX.XX.XX is the version number.

I believe it shipped with the 2021.03.01 release. Check /etc/os-release.
See the README for instructions on how to write this to an SDcard.

Thank a lot for the link. xfce4 work fine.

2021.05 work also but I need to disconnect eth0 to the first boot…

Thank you.

I downloaded the 2021.06 and 2021.07 xfce images and couldn’t get either one to boot.

I tried two different SD cards, neither card would boot the usdk, I tried the ubuntu 21.04 server image on both cards and that did work on both cards. I still have my factory supplied SD card, but I don’t want to risc writing over it.

Does anyone have any suggestion as to why this could be?


You can make dd backup of factory SD card.

There are a few SDcards that people have reported problems with, a Sanyo A2 card, and a Samsung EVO card. But if you can boot Ubuntu from the cards then they are fine.

Since you have apparently never written a freedom-u-sdk image to sdcard before, you might want to check that the image on the card is OK. Mount it on a pc, and verify that you have two mountable partitions /root and /boot which don’t have any file system errors.

Do you have a serial console set up? What if anything do you see on the serial console when it boots?

If you have a bootable image on nvme, then it is possible that there might be something going wrong there, as our u-boot will try to boot from nvme before sdcard. You can interrupt the boot process when it says hit any key to stop autoboot, and then you can use “run bootcmd_mmc0” to force a boot from sdcard regardless of what is on nvme.

Thanks for the replies

The image on the sd card is definitely not ok, it shows up as blank in gparted. this would explain why it doesn’t boot. I tried writing it with both dd and rpi-imager… just to be sure. I will try a different sd card writer tomorrow. Not sure why I can successfully write the ubuntu server image but not the freedom-U-SDK image…

Were you following the instructions in the software manual?
The ‘image format’ is a bit special (if you are used to plain dd images).
I refer to the wic.xz format.

xzcat imaxe.wic.xz | sudo dd of=/dev/sdX bs=512K iflag=fullblock oflag=direct conv=fsync status=progress

Thank you, I was using the *.tar.xz files instead of the *.wic.xz files. Once I downloaded the *.wic.xz files the process went smoothly using the instructions in the manual.

I was able to boot the 2021.07.00 image.