Add software to Xcfe4

apt (or apt-get) does not work.
How to get new application from command or Desktop ?

If you’re using the freedom U-sdk you will need to compile from source. Git and gcc are pre-installed so it’s not too bad you can just follow the directions for installing from source for all your favorite open source software.

The only tough part will be to track down all the dependencies as the freedom-u-sdk is pretty bare bones.

If you want a user friendly OS, try Ubuntu or FreeBSD. There should be images available for other distros too, and more will become available over time as people add support for Unmatched to various distros.

OpenEmbedded is a build from source system, and you only get what you built. If you want to build more than the default, you can update the image list. If you look in meta-sifive/recipes-sifive/images you will see files that specify what packages we build for each image type. You can add your favorite programs and then rebuild the OS from scratch. See for instance
https://github.com/sifive/meta-sifive/blob/2021.07/recipes-sifive/images/demo-coreip-xfce4.bb

Or you can just download sources and build them natively as Olorin mentioned.

2 Likes

Building things anew worked quite well for me. I hope for a ‘new ubuntu version’ before I switch I think.
A couple of SDL and other dependencies are straight forward to follow up.
I haven’t tried ‘mplayer’ yet…

Try git with the text web browser W3M (work well in ubuntu risc-v)
I get all the source files but the “configure” script report:

checking build system type… ./config.guess: unable to guess system type
This script, last modified 2004-03-12, has failed to recognize the operating system you are using.

Where are the (git ?) repository for risc-v tools and applications ?

Thank you.

There is no repository for RISC-V tools. No such repository is necessary or useful.
Everything is upstream if it exists. And if something upstream doesn’t support RISC-V yet, then the patch probably doesn’t exist. There are only a couple of things in the process of being ported that aren’t upstream.

In this case, when config.guess is too old, you can usually just copy a newer config.guess into the source tree and it will work. Only a few programs have target dependent code in them that require porting. Most programs just need a config.guess update. The error message actually tells you what to do to fix this. You can then optionally submit a patch upstream or submit a bug report upstream to let them know.

If you know something has been built for a distro, but does not build from upstream sources, then the distro might have a patch that they are in the process of upstreaming. You can try getting the distro source package which should have the upstream sources plus the patch. Or try checking the bug database or developer mailing list for the package to look for a patch.

1 Like

I copy that. I had several packages that were not aware of RISCV targets yet and taking ANY later config.guess file from an arbitrary other project worked fine for me.