Which Kernel Benchmark is support now?

(John Fireman) #1

Just like the title, I want to test my kernel performance on Hifive Unleashed U540. But I find the kernel benchmark like lmbench, unixbench are not supported RISC-V now, thanks in advance.

(Paul Walmsley) #2

lmbench and unixbench work fine on RISC-V. What problem are you encountering?

(John Fireman) #3

I want to run the whole bench, but for lacking perl, make, I can only run part of them.

(Jim Wilson) #4

What are you running on your HiFive Unleashed? The board ships with a minimal buildroot system that isn’t useful for anything. The very first thing you should do with the board is replace that with something useful. A newer version of freedom-u-sdk for instance, or one of the supported distros like Fedora or Debian.

(John Fireman) #5

Sorry for my beginner question, now, I have realize that point, so I try to using Debian as rootfs, but I find that I can’t use apt:
I use debootstrap to create a chroot floder, and successfully boot and change root to it, but when I following the steps in https://wiki.debian.org/RISC-V#OS_.2F_filesystem_images OS / filesystem images part, I find I can’t use apt to install any software:
root@buildroot:/# apt install emacs25-nox openssh-server
Reading package lists… Done
Building dependency tree… Done
E: Unable to locate package emacs25-nox
E: Unable to locate package openssh-server
But I build the source list obey their instructions:
cat <<EOF > /etc/apt/sources.list
deb http://ftp.ports.debian.org/debian-ports/ sid main
deb http://ftp.ports.debian.org/debian-ports/ unreleased main
deb-src http://ftp.ports.debian.org/debian-ports/ sid main
Do you know how to fix this problem ?

(Bruce Hoult) #6

On my own HiFive Unleashed I’m using the “sifive-debian-demo-mar7.tar.xz” https://github.com/tmagik/freedom-u-sdk/releases. It has both a buildroot partition and a Debian partition. First boot is in to buildroot but then you can edit the uboot config to boot directly into Debian (or do beforehand on a PC, mounting the image after you copy it to a card).

apt-get update, upgrade, install all work fine for me, though space gets a bit tight in the small 6 GB partition provided. Uninstalling the tuxkart game and its data helps a lot.

(Jim Wilson) #7

If apt isn’t working, have you tried ping? Maybe it is a simple network configuration problem. We aren’t the debian experts though. You could try asking on some debian mailing list or chat room.

The debian image Bruce is referring to is on the freedom-u-sdk archive/buildroot branch.

You can create larger partitions for the debian image if you have an SDcard larger than 8GB. There are also ways to enlarge existing partitions and filesystems. resize2fs can increase the size of a filesystem to match the partition size. You have to use some partition tool (fdisk?) to make the partition larger first. I’ve done this a few times, though I use instructions I find elsewhere as I’m not an expert on this stuff.

(John Fireman) #8

@jimw @bruce
I solved my problem because my time was set incorrectly, minicom didn’t create a new line for exceeded part of the output, so I found this problem until I accidentally used a wider terminal, thank you all ! :sunny: