Phoronix Benchmarks


(Jeff Moe) #1

I started running some Phoronix benchmarks over the weekend. They did a mini writeup:

https://www.phoronix.com/scan.php?page=news_item&px=SiFive-RISC-V-Initial-Benchmark

http://openbenchmarking.org/result/1805145-FORK-201805161

Happy hacking,

-Jeff


(John Fireman) #2

Hi, could you please tell me some details about how to test benchmark on H5U ?
I found that all the records in openbenchmarking.org are based on debian, so I guess maybe freedom-u-sdk can not support, so I tried to install debian follow:
https://wiki.debian.org/InstallingDebianOn/SiFive/HiFiveUnleashed
But I got some error when execute: proxychains multistrap -d ./riscv64-chroot -f ./multistrap-riscv64.conf (Host system is Ubuntu 18.04 and I use freedom-u-sdk-v1_0) like:
N: Skipping acquire of configured file ‘main/binary-riscv64/Packages’ as repository ‘http://deb.debian.org/debian unstable InRelease’ doesn’t support architecture ‘riscv64’
E: Unable to locate package XXX
apt download failed. Exit value: 100
And the final directory looks like:
$ tree -L 2
.
├── dev
├── etc
│ ├── apt
│ ├── network
│ └── shells
├── lib64 -> ./lib
├── usr
│ └── share
└── var
├── cache
└── lib
And I directly copy the chroot directory to the origin rootfs, but when I chroot, it successed, but I still can’t use apt.


(Jim Wilson) #3

If you want to bootstrap debian, you probably have to start with a debian host system, and it will have to be a very recent version of debian, as the RISC-V stuff is still new.

It is possible to build a useful system via freedom-u-sdk. The current freedom-u-sdk is instructions for building open-embedded. The previous version of freedom-u-sdk is on the archive/buildroot branch, and has an optional debian rootfs that you can boot into.


(Jeff Moe) #4

It’s been so long since I set it up, I’m not certain how I did it… I am running Debian Buster. I think I booted on the “default” SiFive/HiFive Linux/Busybox image. I created a Debian root installation and copied that to SD card. Then booted HiFive, mounted SD card, and chrooted to the Debian installation there. I saw I had this note, which may be helpful:

toolchain
 sudo apt-get install pbuilder
$ sudo pbuilder create --distribution unstable
$ git clone https://salsa.debian.org/helmutg/rebootstrap.git
$ cd rebootstrap
$ mkdir -p /tmp/repo && sudo pbuilder execute --bindmounts /tmp/repo bootstrap.sh HOST_ARCH=riscv64 REPODIR=/tmp/repo GCC_VER=7


bootstrap

sudo apt-get install debootstrap qemu-user-static binfmt-support debian-ports-archive-keyring
sudo debootstrap --arch=riscv64 --keyring /usr/share/keyrings/debian-ports-archive-keyring.gpg --include=debian-ports-archive-keyring unstable /tmp/riscv64-chroot http://deb.debian.org/debian-ports




bootstrap other
$ sudo apt install mmdebstrap qemu-user-static binfmt-support debian-ports-archive-keyring
$ sudo mmdebstrap --architectures=riscv64 --include="debian-ports-archive-keyring" sid /tmp/riscv64-chroot "deb http://deb.debian.org/debian-ports/ sid main" "deb http://deb.debian.org/debian-ports/ unreleased main"

Happy hacking,

-Jeff


(John Fireman) #5

Thank you! I solved my problem by using Debian as a host system to create chroot, Thank you all :fire:


(Jeff Moe) #6

Great! :slight_smile: