Incorrect Login-Credentials


while trying to set up the HiFive Unmatched I installed the demo-coreip-cli-unmatched.rootfs.wic.xz of the current release (2023.08.00).

When connecting to the board using the UART connection, I receive all the boot-messages which look good, so no error occurs. But if I try to login using the standard-login-credentials mentioned in the github-repo and in the Getting-Started-Guide (root:sifive), I get the message that these are incorrect.

I tried it on the Mac with a US-keyboard as well as on a Linux-device with a german keyboard-layout. I also tried different programs to connect (screen and minicom) and tried it also with the 2023.02.00 release.

What do I miss?

Thanks a lot.

Hello and welcome to the forum!

You should be able to login with the default root password: sifive
Please double check you type it correctly - all letters lowercase.
What UART settings do you use? Should be 115200 8bit.
Can you try with PuTTY app?

When the HiFive Unmatched didn’t accept my login credentials I discovered that the terminal application suddenly had XON/XOFF software flow control enabled. After turning this flow control off I could login.

Another suggestion would be to use copy and paste text instead of using a keyboard to enter the credentials if you suspect that there may be a keyboard or language issue.

1 Like