Freedom Studio on Linux - Getting Started instructions out of date

(Taylor Alexander) #1

I’ve just backed the new HiFive board on crowdsupply.

I’ve downloaded the Freedom Studio package from here:

I’ve downloaded the Freedom Studio documentation from here:

That links to this file:

Note that the PDF manual is dated from December, but Freedom Studio got a big update in March according to this post:

I’ve extracted the .tar archive and executed the FreedomStudio executable and set up a workspace.

The manual says:

However the folder SiFive/Examples does not exist, and I did not see zip files for any platfom nearby. According to the blog post, all this stuff changed last month, but it looks like a change in documentation is needed. At this point, I haven’t figured out how to import examples or compile them. I also do not see the new project dialog touted in the blog post:

Can we get some updated “Getting Started” instructions for the new Freedom Studio? I am unable to compile with the IDE for now, and my board may ship soon. I hope I can have this resolved before it arrives.


(Taylor Alexander) #2

Hey so am I missing something? I am unable to compile the examples on linux and I believe the setup instructions are incorrect. Has anyone been able to compile the examples in the latest IDE?

(Wendy Sarrett) #3

I ran into the same thing. I tried on both linux and windows. So far windows saw the io header but not cout or endl…linux saw neither. I added a number of include libraries to no avail. And yes, there are no samples?!

(Carsten Gosvig) #4

Just noticed that we actually forgot to update the manual on the website for Freedom Studio to match the latest release. We are currently in the process of fixing this.

In the meantime, I propose that you go into the doc/pdf directory in the installation of the latest release. There you can find the manual for that release.

The old examples from 2018 releases won’t compile with the 2019.03 release. The examples are provided in a total new form by the bundled Freedom E SDK. You can find more details in the manual.

Freedom Studio Examples missing
(Carsten Gosvig) #5

The correct version of the Freedom Studio Manual is now live on our website.

(Wendy Sarrett) #6

I downloaded and went through the example and the third screen was not what was in the manual (it said the default config was the only one available and when I clicked advanced I got a null pointer error and if I hit finish I got a null pointer error. When I tried to compile the hello example it complained about not finding make so I probably have to set a path variable. Oh, I was on Ubuntu linux.

(Carsten Gosvig) #7

What happens when you execute “make --version” in a terminal?

(Wendy Sarrett) #8

It had me install make. When I tried make from the IDE it said it had no rule for make all. I checked the makefile and indeed it only had a rule for clean.

(Carsten Gosvig) #9

Did you try to create a new project all over, now that you have make installed?
It needs to be able to run make in order to create a new project in the right way.

(Wendy Sarrett) #10

Thank you for you help!! Yes, later on I tried again to create a project according to the manual and I did get it to work. It must have been that it wasn’t configured entirely initially. I’m now trying to get a C++ project to work and I ran into the issue I’ve run into on other eclipse x-compiling where it find iostream but can’t find cout or endl.

(Carsten Gosvig) #11

Currently our setup in Freedom Studio only supports C project/code development.

(Wendy Sarrett) #12

Ah Ok…tnx!!