Couldn't install sifive version 1.0.6!


(Daniel kirubakaran) #1

I am trying to install sifive 1.0.6 in my arduino library.It shows an error that it is not supporting to my operating system.Mine is ubuntu 18.04 and i tried it in 16.04 also.
Why?due to which reason ?


(Michael Zaidman) #2

The 1.0.6 and the later 1.0.7 are supported for Windows currently. For Linux you still need to use 1.0.2.


(Daniel kirubakaran) #3

Yes, it was working,i tried it in windows.So i need to use the 1.0.2 in linux! alright !
after a long search i came to know that SoftwareSerial32 is now developed for uart devices ,i saw it in cinco-september update from westerndigital github repo.

when i added the URL https://raw.githubusercontent.com/westerndigitalcorporation/CincoWinPkg/master/package_sifive_index.json
to my linux arduino ide (using 1.0.2 only) ,in the packages folder i dont see those libraries for sifive and many files are showing empty.Could you please tell me the issue?

So switched to windows now.

My project is using fingerprint sensor.In windows arduino ide ,i ve installed adafruit_fingerprint library and also included SoftwareSerial32 library. I am getting errors.I have tried my best to make some internal changes in fingerprint library to support softwareserial32.Still getting errors.

Can you compile an example code (can be changepassword) and tell me the problem?

Its urgent.
Thank you in advance


(Michael Zaidman) #4

@daniel

I added support for HiFive1 board to the adafruit_fingerprint library. The pull request is already merged. So, you just need to retrieve the latest code from the repository.


(Michael Zaidman) #5

@daniel

And please use the 1.0.7 version of the cinco package from the westerndigital git repo that fixes the SoftwareSerial32 interrupt deadlock issue.


(Daniel kirubakaran) #6

Great job! Thank you so much.
And yes i 've installed 1.0.7,By the way, have you tested any of those examples?
Because i am getting " Did not find fingerprint sensor :(" error, i have tried some other rx tx pin combinations like 2,3- 8,9- 10,11… for mySerial .But still getting the same errors.


(Michael Zaidman) #7

Great! Glad the library is now compiled for you.
I resolved the compilation problem only but did not run the examples since have no fingerprint sensor.

Please note that for 57600 baud-rate you need to set “Tools->CPU Clock Frequency” to “256MHz PLL”


(Daniel kirubakaran) #8

Oh ok then fine,I will try it out to that freq.:slightly_smiling_face:


(Daniel kirubakaran) #9

Couldn’t make it!:disappointed_relieved:Same errors.