Cannot Run Examples on Freedom Studio 2021.04.0

I have successfully used the early version of Freedom Studio IDE on my computer. But today I found a new version came out and I downloaded it. I ran the demo project, and it didn’t build nor print anything on the CDT console.

No BSP files created. No nothing, it just failed at the beginning and no error is printed.

I hope this is not an April fool joke, because the version number seems not to be correct to me(should be 04.1?)

Someone got idea on it?

1 Like

When you say you “ran the demo project” what does this mean exactly? If you can elaborate on the method you used to create the demo project that would be helpful. Also, if you don’t mind please clarify what you mean by the BSP files getting created. Usually FS will copy them from the location you tell it (some freedom-e-sdk path you select) into the workspace where your project (source, bsp, etc) lives. I don’t know of the expected version being 04.01, but that is most certainly a great observation :slight_smile:

Ok, no offence, here are the steps to reproduce this problem:

First clear the workspace folder.

  1. Open Freedom Studio 2021.04.0, click SiFiveTools->Create a freedom-e-sdk software project.
  2. On the pop-up window, select target “sifive-hifive1-rev-b”, configure it like this:
  3. Press Finish, window closed immediately, the CDT console printed nothing and the project was not built. In the order version like 2020-06-3, at this step it would take a long time to do the cp and rm job, which can be seen on the console.
  4. Check the project folder, only basic project settings there, no other files created, the file tree is like this (printed using tree command on powershell):

│ .cproject
│ .project


I tested the latest release (2021-04-0) both on Ubuntu 20.04 and Windows 10, unfortunately none of them can create the example freedom-e-sdk project. Meanwhile on both platforms, I have no issue working with an older version. :frowning_face:

1 Like

We will be updating the available Freedom Studio version on to 2021.04.1 very shortly, as this version (2020.04.0) has been identified to have issues with new software project generation in some cases. Please check back in the next day or two for the update. Thanks


This is a known problem. It is fixed in 2021.04.1 and will be available on the web before the end of the week.

Oh, good. I thought it was my computer at first, but I literally tried it on all the major OSs, and NADA. This is my first RISC-V board, and I thought I purchased bricks. Very off-putting for a newbie.

Understood, and agree with you. Very off-putting. I’ve just requested that the new version go live. Just waiting for it to happen now. Here’s a direct link to the updated Windows package. Please let me know if you have any additional problems.

1 Like

Kevin, thanks for the prompt response; I’m downloading it now. I’ll let you know if it works.

I’ve been using arduino, and I’ve recently been experimenting with the pi pico - but that’s a problem because of the 3.3v logic. So, maybe these boards hold promise?



Yup, working. Thanks, Kevin. J