Booting Linux

Hello everyone. I am trying to boot Linux in Unleashed board but with no luck so far (yes I know that the old version is not maintained nowadays…). Every possible solution that i have tried from the Internet and github repos either triggers build errors or it has serious problems in cloning the appropriate sources.

I have also tried the archived (buildroot) repo but again with no success. Probably I am doing something wrong but I don’t know what else to try.

So, could someone help me boot Linux by providing the necessary steps? I would really appreciate it.

Thanks in advance,

I haven’t tried building SiFive OpenEmbedded in a while, but it looks like the Unleashed board is still supported. These are the freedom-u540 images mentioned in the latest release notes. I can try a build and see what happens.

OpenEmbedded is a very large and complex project and requires a large and fairly recent set of linux tools. Build problems are common, especially if you haven’t tried building it before. It is hard to say what might be wrong without a better bug report though.

OpenEmbedded is a collection of dozens of different repos maintained by dozens of different people. Sometimes an individual repo will have network connection issues but will work if you try a few hours or days later. Some repos may not support all protocols, e.g. if https doesn’t work try ssh or plain git. Some people have firewalls that only allow certain protocols to pass through. Hard to say what is wrong without a better bug report.

If you don’t need to build it, you can download one of the prebuilt images. If you are on the main GitHub - sifive/freedom-u-sdk: Freedom U Software Development Kit (FUSDK) page, look at the right column for “Releases”, click on it, and then choose one of the freedom-u540.rootfs images to download it. See the instructions for info on how to install it. There are also compressed source tarballs there.

I would not recommend the buildroot archives, those are really old.

Thanks for your answer, really appreciate it.

I managed to boot it finally!!

The steps I followed are :

  1. Download the rootfs image from
  2. Format my SD card
  3. Executed xzcat ./demo-coreip-cli-freedom-u540.rootfs.wic.xz | sudo dd of=/dev/mmcblk0 bs=512K iflag=fullblock oflag=direct conv=fsync status=progress. Be careful here to use the appropriate /dev/... device.
  4. Plug SD in the board
  5. Power the board
  6. Execute sudo screen -L /dev/serial/by-id/usb-FTDI_Dual_RS232-HS-if01-port0 115200. It is important here to execute the command with sudo (or with root privileges otherwise you probably receive the error [screen is terminating].

After these steps, the board boots successfully.