Amazon FreeRTOS on HiFive RevB


#1

Hi, I tried to run an example of amazon freertos on hifive rev B board, the source code from here (https://github.com/sifive/Amazon-FreeRTOS)

I have built successfully aws_demo and aws_test projects by Freedom Studio. However I get some errors when try to download and run program.

The debugger showed that it was trapped in an infinite loop in file entry.S

/* For sanity's sake we set up an early trap vector that just does nothing.  If
 * you end up here then there's a bug in the early boot code somewhere. */
.section .text.metal.init.trapvec
.align 2
early_trap_vector:
    .cfi_startproc
    csrr t0, mcause
    csrr t1, mepc
    csrr t2, mtval
    j early_trap_vector
    .cfi_endproc

In think the issue is in the Debug Configuration.


(vadim) #2

The repository above is targeting learn inventor board (although hifive1 is mentioned in the repo)


#3

Thanks for replying. Can it be used for Hifive1. How to solve my issue


(Jim Wilson) #4

The HiFive1, HiFive1 RevB, and Learn Inventor boards aren’t compatible with each other. The AWS freeRTOS port is just for the Learn Inventor board as far as I know.

But there is a HiFive1 RevB freeRTOS port upstream.


I don’t have a HiFive1 RevB board, so I’ve never tried it and can’t answer questions about it.