Port Freedom E300 SoC for zybo broad successfully


(SandSilicon) #1

Recently, I try to port Freedom E300 SoC for zybo. Today, I implemented the Freedom E300 SoC in a zybo board successfully. I performed a few changes to the repository: added constraints for the zybo board, edited a tcl file in fpga-shells, established a Vivado project and so on.

I implemented the SoC using Vivado 2016.2: added the MMCM and proc_sys_rst IPs manually. To check if the clock and reset are working properly I changed the bootrom contents in xip.S to blink three LEDs, they blink correctly. I also changed the ck_rst and CLK_100MHz.

If there is anything missing, I’d be happy to provide more information about my setup. If you want to get more details, you can follow my GitHub repository: https://github.com/gongqingfeng/freedom_zybo and contact me by e-mail: gongqingfeng1996@qq.com.

Emphasize I’m using the zybo board.


(Boris Shingarov) #2

Hi,
I just tried to look at your github repository, but it doesn’t seem to contain anything other than include the “freedom” submodule referencing SiFive’s repo (where the last commit is from 2017)?
Did you maybe forget to push your code? :slight_smile:
Boris


(SandSilicon) #3

Hello, I edited many file about zybo repository, so I need time to write README.MD. I will push all the file of repository 6 hours later. Please wait.


(Nandakrishnan M) #4

Hi,I’,m new to this and I was trying to implement this on zybo and while running $git clone --recursive https://github.com/gongqingfeng/freedom_zybo.git on ubuntu 16.04, I’m getting the error message fatal:reference is not a tree and Unable to checkout . Pls help me with this. Thanks in advance.


(SandSilicon) #5

I run git clone --recursive https://github.com/gongqingfeng/freedom_zybo.git just now. However, I did not meet this problem. Have you solve this problem?