Not able to connect Hifive1 revb


(Jishnu Chakrabarti) #1

Hello,
I got my Hifive1 board rev b two days back.
I installed SiFive libraries in Arduino IDE and unfortunately, I am unable to upload blink program.

My OS is Mohave.

port seen in arduino is /dev/cu.usbmodemxxxxxxxxx

the error…
Sketch uses 6204 bytes (0%) of program storage space. Maximum is 8388608 bytes.
Open On-Chip Debugger 0.10.0-dev-g9bab078 (2017-01-30-14:28)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
adapter speed: 10000 kHz
Info : auto-selecting first available session transport “jtag”. To override use 'transport select '.
Error: no device found
Error: unable to open ftdi device with vid 0403, pid 6010, description ‘Dual RS232-HS’, serial ‘’ at bus location '

the selected serial port
does not exist or your board is not connected

need help!

update:
I also tried below solution suggested by David Johnson-Davies

I got the same problem on Mac and solved it as follows:

Install Homebrew; see:

https://brew.sh

Install libusb-compat with (in Terminal):

brew install libusb-compat

Conclusion still not working.

I also tried in terminal screen tty.usbmodem0009790002043 115200

but its getting hanged midway!

$ lsusb

Bus 020 Device 003: ID 0a5c:4500 Broadcom Corp. BRCM20702 Hub

Bus 020 Device 006: ID 05ac:828f Apple Inc. Bluetooth USB Host Controller

Bus 020 Device 015: ID 1366:1051 1366 J-Link Serial: 000979000204

Bus 000 Device 001: ID 1d6b:IWPT Linux Foundation USB 3.0 Bus


#2

AFAIK rev B boards don’t work with the Arduino IDE. I might be wrong and there might be a JLink option but I think you need to use the JLink tools to upload a program (that’s been HEX-dumped as well).


(Jishnu Chakrabarti) #3

i think you are right because in hifive1, getting started guide there is no chapter mentioning how to program this board using Arduino IDE.
Bummer!!!