How to launch GUI in Fedora RV64GC port running in Qemu


(Krists) #1

I downloaded the Fedora RV64GC ports (old and new)
Old download - https://fedorapeople.org/groups/risc-v/disk-images/
Old instructions - https://wiki.qemu.org/Documentation/Platforms/RISCV

New download - https://dl.fedoraproject.org/pub/alt/risc-v/disk-images/fedora/rawhide/20190703.n.0/Developer/
New instructions - https://fedoraproject.org/wiki/Architectures/RISC-V/Installing#Boot_the_image_on_virtual_hardware

With old image I managed to succesfully install KDE (GUI desktop enviroment), but I can’t launch it. When I tried to “startx”, it just said that there is no screens found. I also tried to change Qemu launch options, but without success

New image boots and kinda works, but I can’t even download KDE via package manager. It shows me “No match for group package”, which vorked in old version.

Is there a way to get KDE running (Preferably on Debian, but Fedora is also ok) on RV64GC without spending $3000 + dedicated gpu for real RV64GC hardware. For me command line is very painful. Does any body have some links to get DE GUI working in QEMU?


(David Abdurachmanov) #2

Hi!

Fedora/RISCV maintainer here. We have not tested KDE before. We have validated GNOME Desktop on hardware setup, but we don’t build those images frequently (very little users right now). Fedora/RISCV Developer Rawhide image is X11 capable and incl. fluxbox, i3, awesome out of the box. Those have been tested on TinyEMU and QEMU some time ago. This is exactly what boots in JSLinux: Linux 4.15.0 (Fedora 29) + X Window configuration: https://bellard.org/jslinux/

The biggest desktop environment I have tried on QEMU was Xfce and that was already slow for me.

For QEMU GUI I would stick to X11 + fluxbox, i3, awesome or something else in the same category.