HiFive1 setup issue

Hi. I’m working on a 64-bit PC, running on windows 10. I have a HiFive1 board, and I want to connect it to my PC with a USB-to-MicroUSB cable. I’ve connected it, and the lights on the board were blinking, just as it supposed to go.
However, I can’t see my board on any program like Zadig, that helps with USB drivers. The board just doesn’t show there, and I don’t know why.
I tried to write programs to the board using PlatformIO, and it didn’t find a version of the openocd tool suitable for my OS.
So I tried to run Ubuntu 14.05 on VirtualBox and set up the board from there.
But, as I said, I can’t get access to the board via USB, and because of that, I can’t give the VM access to the USB.
I tried many ways of installing the toolchain, and none of them could upload the code to the board, some of them won’t even install.

Can someone tell me what should I do?
Thank you

We have a very good step-by-step tutorial for FTDI/Zadig in our forums. Could you try this solution?