Hifive1-revB no longer connecting?


#1

I think I might’ve busted the USB socket on my Hifive1-revB. I’ve had it working fine previously.

I’ve been busy recently so I didn’t use it for a couple months and coming back now I don’t even get a blimp in the kernel about the USB.

The device itself works from the USB port tho, it gets powered and I can also enter the “rescue” mode with blinking LED so the CPU is fine too.

There’s nothing if I reconnect the device, no loss or new device in DMESG. I tried a separate usb cable and also in Windows just to be sure (windows used to find it as well).

NOTE: I didn’t change the main program on the device since last time it worked, I’m pretty sure this is on the “connectivity” side.

Is there some other way I can connect? Any way to measure-debug the data lines on the usb socket maybe?


#2

Turns out another machine running older Arch Linux with kernel 5.3 works fine.

I think the issue has to do with kernel 5.4 since that’s what my main machine is running (also Arch Linux, mostly identical, just updated more).


#3

Turns out the device has some sort of usb power or timing issue and only works via a USB hub, at least on this machine.

It’s a bit odd but I got it working again via the HUB so “good enough” ™