Freedom U500 VC707 Error while flashing

Hi all,
I have been following “SiFive Freedom U500 VC707 FPGA Getting Started Guide” to boot linux on Virtex-7 FPGA VC707 board. I’m getting the following error when i’m trying to flash .mcs and .prm files

MCS programming start address 0x06000000 should be a multiple of the flash program buffer size (20971520/0x1400000 bytes).
ERROR: [Labtools 27-3161] Flash Programming Unsuccessful
ERROR: [Common 17-39] ‘program_hw_cfgmem’ failed due to earlier errors.

I am using Windows(10) OS and Vivado 2016.1 Lab edition . I have connected both UART and JTAG cables to the board. I have set VC707 boot mode as suggested. But i don’t have “HiTechGlobal X8 PCI Express Gen1/2/3 FMC Module (Vita57.1)” as mentioned in guide.

I would appreciate some guidance on how to solve the error.

Hi @sunb,

Hmm… I just did this successfully on Linux. Might be worth it to double check the sha1 hashes vs the files you have:

$ sha1sum *
8774928848a7e28300dc9f63765b50e664dde438 freedom-u500-vc707-0-1.mcs
69c07aadcf24399faadabde3b270877925158f86 freedom-u500-vc707-0-1.prm

Also, I had some issues with switch settings in the past, but it didn’t give those exact errors. And I know vivado will emit a program_hw_cfgmem sometimes with uncompressed memory images (but if you’re using the .mcs file from the SiFive, this shouldn’t be the case.)

Can you flash a different .mcs file? Maybe there’s some config problem with the board or with your PC?

As chance would have it, I’m reflashing my VC707 later this evening. If you’re still having problems… I have a windows machine somewhere with the vivado toolchain somewhere. I’ll see if it’s 2016.1 and try it from there and take notes.


hi @mhamrick,

Thank you for your prompt reply. The sha1 hashes of my files matches with the values that you have mentioned.

I have tried flashing different .mcs files( downloaded from Freedom U500 VC707 FPGA Dev Kit Bitstream, all three versions) and I’m getting the same error.

Apart from setting VC707 boot mode as suggested in the guide, I haven’t done any other configuration on the board. On PC(Windows 10) side, after launching Vivado(2016.1 Lab edition), I clicked on “Open Hardware manager”->“Open Target”->“Auto Connect” which automatically connected to the hardware.

I have tried installing Vivado(2016.1 Lab edition) on Ubuntu(14.04 64-bit) but i was unable to find the compatible drivers. With no drivers target hardware is not getting detected.

Could you please let me know whether you have tried it.

Thanks ,

As a sanity check, you selected the following SPIFlash parameters, correct?

59 AM

This is orthogonal to your MCS programming issue - but if you do not have the PCIe FMC card, the pre-compiled bitstream will not boot Linux. The reset circuit waits for the MMCM in the PCIe IP to lock, which never happens because there is no PCIe REFCLK coming in from the PCIe FMC card.

To run without the FMC module, you should rebuild the bitstream from the following branch :

Hi @mwachs5,

Thank you for your reply.

Yes, the parameters are correct. I have selected the same SPIFlash paramaters.

I have done Built-in-self test on board before flashing and the board seems to be working fine.

The problem might not be with .mcs file because i have checked sha1sum of the files as suggested by @mhamrick , the values are matching. Also I have tried flashing different .mcs files and I’m getting same error.

Need some help to solve this problem.

Hi @henrystyles,

Thank you for your reply. I will keep that in mind :slight_smile:

And more news. I was finally able to install vivado on windows and can verify flashing from windows and linux both worked fine for me.

hi @mhamrick
Thanks for your reply. We finally found out that the problem is with board hardware.

We were able to flash bitstream in new VC707 board :slight_smile: