Cannot build the attached project at FreedomStadio Windows version

I am new to the eclips environment. I have the HiFIve1 board and tried to the FreedomStadio Windows version. However I faced the trouble not be able build a project.First of all, I imported the demo_gpio project which is located in the Example folder of the FreedomStudio .ZIP packege after melting the
When building the project, I got the following message.

13:36:18 **** Build of configuration Debug for project demo_gpio ****
make all
make: *** No rule to make target D:/FreedomStudio-Win_x86_64-20170616/FreedomStudio/SiFive/bsp/env/freedom-e300-hifive1/init.c', needed bybsp/env/freedom-e300-hifive1/init.o’. Stop.

13:36:22 Build Finished (took 3s.964ms)

However init.c is at D:\FreedomStudio-Win_x86_64-20170616\FreedomStudio\SiFive\Examples\\demo_gpio\bsp\env\freedom-e300-hifive1.
What is wrong? What should I do to solve this?

Best regards.
Yasuhiko Koumoto.

Hi all,
because there is the following message "make: *** No rule to make target ‘D:/FreedomStudio-Win_x86_64-20170616/FreedomStudio/SiFive/bsp/env/freedom-e300-hifive1/init.c’, needed by ‘bsp/env/freedom-e300-hifive1/init.o’. Stop.
", I copied the “bsp” folder to “D:/FreedomStudio-Win_x86_64-20170616/FreedomStudio/SiFive”.
Then, building went a little further and was stopped with the message “make: *** No rule to make target ‘D:/FreedomStudio-Win_x86_64-20170616/FreedomStudio/SiFive/software/demo_gpio/demo_gpio.c’, needed by ‘demo_gpio.o’. Stop.”.
So, I made the “software” folder and copied the “demo_gpio” folder to there.
And then, building seemed to finish successfully.
However I don’t know whether it would be the right way.
And then, I tried to run the program but it failed with the message “Cannot run program “D:\FreedomStudio-Win_x86_64-20170616\FreedomStudio\SiFive\Examples\HiFive1\demo_gpio\Debug\demo_gpio.elf”: Launching failed”.
What was happened? What should I do?
Best regards,
Yasuhiko Koumoto.

Hi all,
the root cause was my operation mistake.
I chosen the “Open Project form File Sysytem…” command instead of “Import” to import projects.
There were no problems to build the projects.
Best regards,
Yasuhiko Koumoto.

1 Like