Can SPEC CPU®2017 run on RISC-V architecture?

I try to run SPEC CPU@2017 on HiFive Unleashed。

We do not appear to have working vendor-supplied binaries for your
architecture.  You will have to compile the tool binaries by
yourself.  Please read the file

    /home/root/cpu2017/Docs/tools-build.html

for instructions on how you might be able to build them.

Please only attempt this as a last resort.

in tools-build.txt:

1.b. Pre-compiled binaries

   You will find pre-compiled binaries for the tools on your distribuion
   media, in the directories:

 tools/bin/<archname> (Unix)
 tools\bin\<archname> (Microsoft Windows)

   After installation, the above directory will be found underneath $SPEC
   (Unix) or %SPEC% (Windows).

   The appropriate set of precompiled binaries is automatically installed
   when you run install.sh (Unix) or install.bat (Windows).

but there is no riscv pre-build binaries under tools/bin.

it seems SPEC CPU@2017 does not support RISC-V architecture

Do you have a link for this?

https://spec.org/cpu2017/

Someone has to join SPEC, build RISC-V binaries, and contribute them soon enough to be included in a release. The lack of official RISC-V linux distro releases makes this even more complicated as you would have to target an unofficial distro release, and no guarantee things still work the same when an official release comes out, which means even more binaries will have to be built and merged into SPEC CPU. And there is also the issue that no one has tested compatibility across linux distros, as there are no official releases that can be tested. It will take some time before SPEC CPU will have RISC-V support.

Meanwhile, if you want to run cpu2017 then you need to build the binaries yourself.

I haven’t tried running cpu2017 yet. It is about 14 hours for one iteration cpu2006 int on unmatched, and about 34 hours for one iteration cpu2006 fp. Unleashed is a little slower than unmatched. cpu2017 probably takes even longer to run. But is is probably easier to build the tool binaries for cpu2017 than for cpu2006. The ~20 year old tool sources in cpu2006 are very difficult to build on a modern linux system.

2 Likes