Unmatched desktop builds

this was a great video!

was the graphics performance worse on ubuntu vs openembedded?

im on a 4k monitor and openembedded is a bit sluggish even though i have a 4GB rx 550… i wonder if its the same issue…

(unfortunately, i havent been able to boot get ubuntu booting at all)

Thanks for the kind words. I honestly went straight to that Ubuntu image. I haven’t actually touched the card that came with the Unmatched.

My dual monitors are 1920x1200. I have Displayport out → DVI adapter → KVM for the main monitor.

My secondary monitor is using the VGA out of the sapphire directly to the port on the monitor (I have to switch inputs manually on my 2nd monitor).

I’m not really a benchmark kind of guy, but maybe I should look around and see what’s available to run. Maybe it’s “radeon” vs “amdgpu” after all, but I guess could be CPU throttling? I’m not sure of the nuances between X and Wayland as far as leveraging the GPU.

Sure, moving around in the UI is a bit sluggish, but I’m so eager to find out what is or is not available in apt that I haven’t given the graphics driver a second thought today. It’d be nice to see what’s going on and make things better there, but it’s not crippling my explorations of other things.

I really think the only seriously annoying perf issue I’m seeing is the one in Epiphany…which I’m pretty sure is the JS engine (not V8).

yes, i have no scientific evidence, but it seems to me the ui is not accelerated, and the js engine in epiphany seems to be missing some perofrmance (not using jit?)

other than that id say performance seems pretty acceptable

and ill try ubuntu again, glad someone was able to get it working on the first try!

and maybe sometime ill try to make a video too ^^

here is my desktop

  • CASE: JONSBO T8
  • POWER SUPPLY: Corsair SF750
  • GPU: MSI Radeon RX 550 AERO ITX 4G
  • STORAGE: Samsung 970 EVO Plus 500GB
  • CPU FAN: AINEX OMEGA TYPHOON
  • MONITOR: LG 32UD99-W 4K

i pick this case because i dont like a computer i cant throw…

built retroarch and run some snes demoscene

hopefully next i could get obj-c / gnustep building…

2 Likes

I still haven’t tested the card, but i did test a different card (an old/passive cooled nvidia NVS300), and it worked. It showed me the console login and (of course) it showed up in lspci. It still tells me nothing about the other card, but it does prove the unmatched is ok.

Great looking build and good to see retroarch running snes games, I installed the one from the ubuntu repos and am currently getting an error stating “*** longjmp causes uninitialized stack frame ***: terminated”. I’ll check later for the actual wording, but i get that error when launching both snes and n64 games. Gba/gb games seems to run just fine.

Glad to hear your board is fine.

yea, it took all night to build all the emulator cores, ive tested genesis/megadrive and snes, i wanted to try some psx/n64 soon

only a few of the cores couldnt build (such as dosbox and ffmpeg)

they seem to all run pretty well (though not while running a compilation on all cores concurently)

My first run of the unmatched (still with the Radeon which I replaced with an RX550 by now).
Hooked up to a Nexdock2 to have the mouse+keyboard and big screen for the ssh and research work (still).


Thank you SiFive for this step!

Small updates in a second video.

I have already made the switch to KDE in real time, though this 2nd video, and probably a third one eventually, are all footage of installing and playing around programming while on the Gnome desktop from the original install.

I’m finding I prefer KDE on the unmatched, and I went with kde-full to see what all came along and how it worked. But man…if you thought epiphany struggled, it looks like a champ compared to how poor Konqueror is doing on the Unmatched. Not just speed, but Konqueror is not rendering pages with near the fidelity that epiphany was.

2 Likes

I suspect there is no functional JavaScript compiler for RISCV. At least chromium doesn’t have a RISCV backend yet and a browser nowadays is a big compiler!

V8 is not fully baked on RISCV and V8 beats WebKitGTK, but yes, it would be interesting to know if WebKitGTK on RISCV has shortcomings even compared to WebKitGTK on ARM or on Intel.

I am not up on the latest intricacies of javascript engine since I’m mostly backend development and don’t use Node. I have watched some videos on the RISCV work on a port, but don’t recall the exact status.

I ran some trivial node programs on the Unmatched already to test this version of node, but I haven’t documented that yet.

My Haiku RISC-V desktop. Graphics card is Radeon R7-250. Tablet on left side is used as UART terminal.


Screen with Haiku:

5 Likes

That is a gigantic case for the tiny Unmatched board but I guess it is a nod to the old BeOS cases from 20 years ago.

I haven’t found small case that can fit PCIe graphics card and not unreasonably expensive.

I found an old school full tower case at the thrift store and built my unmatched in that with an Rx 570 and some LED fans and RGB strip for flare. I have an nvme in there but haven’t gotten around to booting the system from that yet.

2 Likes

Am trying to make a CASE of 230x200x125mm, expense is expected to be <20$ if cut from acrylic plate.


230mm because I’ve a 220cm RX580, could be shortened to 175mm without it.

I’ll share the design file when finished, with photo of unmatched installed, for you to customize.
You can use aluminium plate if budget allows.

2 Likes

  • Case: Silverstone SST-RVZ03B-ARGB
    • HiFive1 Freedom E310 development board (case LED control)
  • Motherboard SiFive Unmatched + stock cooler
  • GPU: Asrock Radeon RX550 2G
  • SSD: Samsung 970 EVO Plus 2TB M.2
  • PSU: be quiet System Power 9 500W
  • KALEA-INFORMATIQUE M2 E Key Adapter card to PCIe 1x / USB
    • DeLock USB 3.0 19 pin PCI Express x1 card (for case USB)

The system boots RISC-V Debian from NVMe, with a manually configured kernel (based on freedom-u-sdk’s) to enable some things like Wacom tablet support. I’ve installed a AMD RX550 GPU, driving a run of the mill HDMI monitor. It can do 1920×1080 video playback with VLC, sound works great through HDMI as well. 3D rendering with OpenGL works. Vulkan doesn’t (due to lack of mesa-vulkan for Debian RISC-V) Vulkan works but you might need to build the driver yourself.

As desktop environment I’m using wayland+sway.

Currently I’m mostly using it for RISC-V software development, as well as testing whether certain software runs on RISC-V.

This case actually contains two SiFive RISC-V boards :smile:. I ditched the stock 8051-based case led controller for a HiFive1 Rev A (which can do the required 5V I/O). It runs a firmware that takes commands over USB serial and drives a WS2812 led strip through the built-in SPI peripheral. The board is overpowered for this but it might be useful for other embedded controller tasks later.

Edit: I’ve now open-sourced the firmware here: GitHub - vmedea/hifive1-argb-fx: HiFive1 as ARGB led controller board

See it below running the FREE (and awesome) game Lure of the Temptress.

Nice to see that ScummVM games work.

4 Likes

How do we get mesa-vulkan?

Finally got it, in 3mm acrylic plate. Cost of the 6 plates is $4.1.


Case design in FreeCAD

4 Likes