TFTP boot with U-Boot

Hi, I’m trying to use TFTP boot by manually interrupting U-Boot and executing the dhcp command, but unfortunately, it doesn’t work.

=> dhcp
ethernet@10090000: PHY present at 0
ethernet@10090000: Starting autonegotiation...
ethernet@10090000: Autonegotiation complete
ethernet@10090000: link up, 1000Mbps full-duplex (lpa: 0x7c00)
BOOTP broadcast 1
ethernet@10090000: TX timeout
BOOTP broadcast 2
ethernet@10090000: TX timeout
BOOTP broadcast 3
ethernet@10090000: TX timeout
BOOTP broadcast 4
ethernet@10090000: TX timeout
BOOTP broadcast 5
ethernet@10090000: TX timeout

Is this a known issue?

I’m using dnsmasq with the following command on the other side and if I boot into Linux on my Unmatched, it successfully gets an IP address:

sudo dnsmasq --no-daemon --listen-address=192.168.1.10 --bind-interfaces -p0 --dhcp-authoritative --dhcp-range=192.168.1.100,192.168.1.200 --bootp-dynamic --dhcp-boot=/home/user/unmatched/kernel.bin --log-dhcp --enable-tftp --tftp-root=/home/user/unmatched/