Terminal in FreedomStudio Showing Garbled Output


#1

Hello everybody,

I am trying to get up and running with FreedomStudio against an Arty A7 flashed with the E300ArtyDevKitFPGAChip.mcs . Both the FreedomStudio and the E300ArtyDevKitFPGAChip.mcs
are very recent, the .mcs is from a local build of the source tree.

One problem I have is with the terminal inside FreedomStudio.
I can’t get the terminal to show anything else than garbled output, for example,
on running the hello-world program that comes bundled with FreedomStudio. Stepping through the
program inside the debugger indicates that it works, although it does not seem to terminate (intentionally?). I tried switching back and forth between the different character encodings,
which did influence the way the garbled output looked. But it never became readable.

It seemed to work sort of when I used Vivado to flash a pre-built .mcs that I had downloaded
earlier. I could then connect from an ordinary Linux terminal using screen and the output
(an ASCII rendering of the SiFive logo) was readable.

Any help on that would be greatly appreciated.

/Mike


(Tommy Murphy) #2

Are you absolutely sure that the target and terminal are using the same uart settings/baud rate?


#3

In the end it worked when I started a terminal with the following parameters:

Baud rate: 57600
Data size: 7
parity: Even
Stop bits: 1
Encoding: UTF-8