Problem when building freedom toolchain: build process gets stuck


#1

I am trying to build the freedom toolchain. The build process gets stuck at a seemingly early stage. The last output reads “config.status creating Makefile”. Prior to that, the only noteworthy I can find are messages reading “This configuration is not supported in the following subdirectories:”, each followed by a list of directory names.


(Jim Wilson) #2

The messages you mention are normal messages during a build, and so don’t tell me anything useful. Those messages are not echoed to the output but rather redirected into files, with different files having different output. You didn’t mention which file you were looking at, but the config log files are supposed to end with a creating Makefile messge, that is normal. The build output then goes into a different file.

Why do you think the build got stuck? Do you see a processing using hours of cpu time? Which process? Maybe the build is progressing and you are looking at the wrong log file?


(Jim Wilson) #3

We support builds on Ubuntu, Red Hat/Centos, and macOS via homebrew. If you are on a different system there could be issues.

If you are on Ubuntu, then by default it will build both the ubuntu and the windows tools. You can build the ubuntu only tools by doing “make ubuntu64” assuming you are on an x86_64 system.


#4

I understand that more details are required on the question that I posted. To this end, I ran make with a tracing option. The log that I obtained from that can be found here:

Hope this helps.


(Jim Wilson) #5

I think the real error is in here
cd obj/x86_64-linux-ubuntu14/build/expat/; ./buildconf.sh &>make-buildconf.log
You are probably missing the autoconf package.


(Jim Wilson) #6

The prerequisites section of the README.md file lists the packages that need to be installed before you can build freedom-tools.


#7

autoconf exists as a binary on my system.


(Jim Wilson) #8

Did you look in the make-buildconf.log file?


#9

Several log files are generated. The only file of this precise name is empty.


(Jim Wilson) #10

The cd command makes it clear that I’m talking about the make-buildconf.log file in the expat build dir. I don’t know how it could be empty. Try manually running the buildconf.sh file to see what happens.

There is something wrong on your end. You might need to start over, e.g. check out a new freedom-tools tree, and do a build with make -j1 to get easier to read log files, and look at the errors to see why it is failing.

If you think the build is hanging, then use ps or top to see which process is hanging.


#11

Thx. It’s still not solved on my side. However, I have (only now) discovered the pre-built toolchain. This one seems to work better.


(Carsten Gosvig) #12

We are building on a Ubuntu 16.04 system.
Could you make an ls of the /usr/local/stow/freedom-tools/freedom-tools-19.02.0/checkout-build/freedom-tools/obj/x86_64-linux-ubuntu14/build/expat directory and list the content of make-buildconf.log.
It needs to be possible to make a build.