Freedom u-sdk not building on Ubuntu 18.04


(Fahad Mubeen) #1

Hi All I am using Ubuntu 18.04 (VmWare), and freedom-u-skd doesn’t build on it, I followed every step in the guide. First I install all the softwares using the following command.

sudo apt-get install autoconf automake autotools-dev bc bison
build-essential curl flex gawk gdisk git gperf libgmp-dev
libmpc-dev libmpfr-dev libncurses-dev libssl-dev libtool
patchutils python screen texinfo unzip zlib1g-dev

Then I run the following commands to checkout and make freedom-u SDK

git clone https://github.com/sifive/freedom-u-sdk.git
cd freedom-u-sdk
git submodule update --init --recursive
make

but I get the following error.

make: *** No targets specified and no makefile found. Stop.

What is I am missing, manual doesn’t mention anything, I am currently working on HiFive Unleashed board.


(Jim Wilson) #2

freedom-u-sdk has been deprecated and replaced with an open-embedded layer. If you read the current README.md file, it tells you to use meta-sifive instead and explains how to build it. The current version of the freedom-u-sdk sources contains only the README.md file.

If you want the first version of the freedom-u-sdk sources used to build the original Freedom Unleashed images, you can find it on the v1_0 branch. However, this is an extremely limited system not useful for any real development, so there is little reason to use it.

If you want the second version of the freedom-u-sdk sources that have m-mode u-boot and debian rootfs support, you can find it on the archive/buildroot branch. This one can be used for real work.

The third version of freedom-u-sdk is an Open Embedded layer and the actual sources are elsewhere but the README.md file should work. This is pretty new. I haven’t tried this myself yet.