Freedom Studio on Ubuntu 18.04 launch problem

When I launch Freedom Studio a dialog box pops up that says:

‘Initialize SDKs’ has encountered a problem.
An internal error occurred during: 'Intialize SDKs".

when I click on the Details button it says:

An internal error occurred during: “Initialize SDKs”.
bad input for FESDKOptions()

Does anyone know how to fix this?
I can’t seem to create any new projects from the SiFive menu item:

“Create new Freedom E SDK Project”

Thanks for any help!

Can you please provide some more details?
Did you download the latest FreedomStudio from
Did you had any issues when intallng FreedomStudio?
Where did you install FreedomStudio ? location ?
Where did you point the workspace to?


No issues installing.

Installed into a folder in my documents folders. Used default workspace.

I noticed a makefile in the freedom-e-sdk-201906 folder and ran it. It gave me errors for not having all the build tools installed.

Reran the freedom studio and now the example projects were there to build!

For reference, the “bad input for FESDKOptions()” error message is generated when Freedom Studio runs the following command in the freedom-e-sdk folder:

make list-options

If you see this again, try running this in a shell and paste the output here.


I reinstalled Ubuntu 18.04.4 onto a new hd in my laptop.

I downloaded Freedom Studio from the link you provided…

I got the same error. “make list-options” fixed everything.

Freedom Studio launch on Ubuntu 18.04 WSL2.0 problem regarding GTK3 fixed:

Summary: Freedom Studio Bug Report

Installation of Freedom Studio on WLS2.0-Ubuntu-18.04-LTS requires updating GTK3 by performing the following:

“sudo apt-get install libgtk-3-dev”

See this URL for more details:

The suggested action has worked nicely for me, to get to this point.

Actual text of the Error log:

!SESSION 2020-06-15 20:33:53.833 -----------------------------------------------
JRE 11 Linux amd64-64-Bit Compressed References 20190531_239 (JIT enabled, AOT enabled)
OpenJ9 - b8ab01656
OMR - b56045d2
JCL - dcdc97f9dc based on jdk-11.0.3+7
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=c.u_US
Framework arguments: -clearPersistedState
Command-line arguments: -os linux -ws gtk -arch x86_64 -clearPersistedState

!ENTRY org.eclipse.osgi 4 0 2020-06-15 20:34:06.779
!MESSAGE Application error
java.lang.UnsatisfiedLinkError: org/eclipse/swt/internal/gtk/OS._cachejvmptr()V
at org.eclipse.swt.internal.gtk.OS.cachejvmptr(
at org.eclipse.swt.internal.gtk.OS.(
at org.eclipse.swt.internal.Converter.wcsToMbcs(
at org.eclipse.swt.internal.Converter.wcsToMbcs(
at org.eclipse.swt.widgets.Display.(
at org.eclipse.ui.internal.Workbench.createDisplay(
at org.eclipse.ui.PlatformUI.createDisplay(
at org.eclipse.ui.internal.ide.application.IDEApplication.createDisplay(
at org.eclipse.ui.internal.ide.application.IDEApplication.start(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.base/java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(
at org.eclipse.equinox.launcher.Main.basicRun(
at org.eclipse.equinox.launcher.Main.main(