Error display on reset - Send Flag Timed Out Busy

Whenever I reset a program (with the button), I get the following Terminal output on COM7:

Bench Clock Reset Complete

ATE0–>Send Flag Timed Out Busy. Giving Up.
Send Flag error: #0 #0 #0 #0 AT+BLEINIT=0–>Send Flag Timed Out Busy. Giving Up.
Send Flag error: #0 #0 #0 #0 AT+CWMODE=0–>Send Flag Timed Out Busy. Giving Up.
Send Flag error: #0 #0 #0 #0

Followed by the expected display from the particular example program. I tried using a separate power supply of 7 to 10 volts on the power input connector but that made no difference. Could my ESP32-SOLO part be broken? I get no output on COM6. The fe310-g002 works and the JLINK debugger works.

win 7 64
HiFive1 Rev B board
SiFive Eclipse IDE for C/C++ Development Version:

Problem solved. When I use putty to connect to COM6 (the ESP32-SOLO thru MK22FN), I need to enable flow control RTS/CTS. I found that pin 3 - EN of the ESP32-SOLO was at 0.3 volts - should be hi. The FE310 attempts to enable ESP32-SOLO but the MK22FN disagrees. MK22FN pin 44 -> DBG_UART1_RTS connects to WF_RESET_R.

FE310 running hifive1revb_wifi from kjarvel

My setup appears sensitive to the order of power on, reset, connecting putty etc. This works sometimes:

  1. Plug in USB
  2. Open 1st putty on COM7
  3. Push RESET

output is:
Bench Clock Reset Complete

  1. Open 2nd putty on COM6
  2. Press RESET again
  3. ESP/wifi boot up displays on COM6

Note: once I used putty on COM6 with RTS - something now remembers that setting even without connecting putty to COM6.

1 Like