Cannot reprogram expansion board


(ryanmendels) #1

Hello everyone
I cannot seem to be able to reprogram the expansion board. I have programmed it once with the flash pro 5 but the next times the program tells me that the vjtag cable is not connected when it is. Is there a switch I need to move on the expansion board to make it able to reprogram?

Thanks!


(Troy Benjegerdes) #2

I recall a message similar to that if I don’t have the expansion board power switch turned on.


(ryanmendels) #3

The expansion board is turned on, but I still get the same error message (vjtag cable disconnected or shorted). I have the vjtag cable plugged into the board vjtag header yet it’s not working. The program does not detect the flash… I saw there is SW5 and other buttons, is there one I need to press or something to enable flashing again?


(kaedan38) #4

I’m having the exact same problem. Please advise.


(ryanmendels) #5

Hi,
If I wait a day and keep the expansion board offline it detects the flash but it detects the wrong type? It detects as MPF300XT instead of MPF300TS_ES.

STAPL file ‘C:\HFU540_EXP_Bitstream_r10101.stp’ has been loaded successfully.
DESIGN : PCIe_ChipLink; CHECKSUM : E706; ALG_VERSION : 1
Scan Chain…
Scan Chain PASSED.
Executing action PROGRAM
EXPORT ERROR_CODE[16] = 8004
Failed to verify IDCODE
Finished: Thu Jul 18 00:10:52 2019 (Elapsed time 00:00:00)
Error: Executing action PROGRAM FAILED, EXIT 6, refer to FlashPro online help for details.

Thanks…


(Troy Benjegerdes) #6

Is this one of the recent boards that were just available on crowdsupply, or one that you’ve had around for a long time? Also where did you get the .stp file from?


(ryanmendels) #7

Yes, it’s one of the recent boards from crowdsupply. I downloaded the bitstream .stp file from https://www.microsemi.com/document-portal/doc_download/1243348-polarfire-fpga-bitstream

Both FlashPro and FlashPro Express don’t let me flash the board anymore.
I’m getting either the below error or vjtag cable/flash not detected not connected error:
Error: Device 1: Found: MPF300XT, Expected: MPF300TS_ES

I checked and my FPGA model on the expansion is indeed MPF300XT.

STAPL file ‘C:\HFU540_EXP_Bitstream_r10101.stp’ has been loaded successfully.
DESIGN : PCIe_ChipLink; CHECKSUM : E706; ALG_VERSION : 1
Scan Chain…
Scan Chain PASSED.
Executing action PROGRAM
EXPORT ISC_ENABLE_RESULT[32] = 00000000
EXPORT CRCERR[1] = 0
Programming FPGA Array and sNVM…
Error: Microsemi FlashPro3/3x/4/5 Programmer has been disconnected. Please check connection.
Finished: Sat Jul 20 09:23:58 2019 (Elapsed time 00:00:00)
Error: Executing action PROGRAM FAILED.

                    o - o - o - o - o - o

It still doesn’t want to flash after trying many different things…