Booting issues when interfacing Expansion board with HiFive Unleashed Development Board


#1

I can’t seem to trigger any activity or responses from the expansion board when connected to our HiFive development board (running linux from Feedom U SDK dir.). Pretty much followed the startup guide (HiFive Unleashed Expansion Kit: Quickstart Guide (loaded the bitstream onto board via Polarfire)).

Tried putting a RAID controller on the PCIe x16 to trigger some sort of action. But it didn’t really make a difference (tried command lspci and checked the /sys/bus/pci/… directory too. but it was empty). Nothing is connected to the RAID controller, but I think it should still work for testing purposes.

I’m not sure if the quickstart guide is missing any information on getting the development board to work with the expansion board, does anyone have any information regarding the setup that I could be missing? It basically runs like the expansion board isn’t even there.


(Jim Wilson) #2

Do you have the modified device tree with a node for the Microsemi expansion board? Has it been hacked into your bbl (preferably), or did you build your own FSBL from source with the updated device tree and flash it to the board (not preferred)? Do you have the non-upstream Microsemi PCIe driver? All 3 of those are required to use the expansion board.

The best source of info is Atish Patel’s page explaining how he got his board working


#3

So SiFive hasn’t released any official documentation that goes over how the expansion board is integrated with the SiFive Unleashed development board?


(Jim Wilson) #4

We have a lot of useful documentation for the SiFive Unleashed board. We don’t have any useful documentation for the Microsemi expansion board. You can get some info from Microsemi for that. Atish Patel got linux working on his board with help from SiFive, and his web page is a good explanation of all of the steps necessary to get the Microsemi expansion board working with the SiFive Unleashed board.