I've been trying to connect my hifive unleahed using usb


#1

I tried connect my hifive unleashed with my PC using usb to figure out IP.
So I typed sudo screen /dev/serial/by-path/*-port0 115200 in my ubuntu terminal.
but i can’t get anything about login prompt except black screen.
Could you help what i have to do.
By the way I am using ubuntu 18.04.1 LTS
Plz help me, i’m in real trouble
thank you


(Jim Wilson) #2

The board provides two serial ports. One is the serial console, and the other is for JTAG. The exact numbering may depend on what you are connecting with, so if the first serial port does not work as a console, try the second one. Normally, one would use /dev/ttyUSB0 or /dev/ttyUSB1. I need to use /dev/ttyUSB1 on my primary machine.

By using “sudo screen /dev/serial/by-path/*-port0 115200” you are actually passing two serial ports to screen. Perhaps that is why it doesn’t work. I use minicom personally, so I’m not sure how screen works in this case.


#3

Hi Jim, Thank you for your kind answer. it’s really appreciate. However it doesn’t work for me. :disappointed_relieved: I tried to find ttyUSB0 but i can’t find this directory. and I typed other instruction many time. However result are same, i can’t get anything about login prompt. Have a nice day Jim.


(Jim Wilson) #4

You have to power on the board before /dev/ttyUSB0 or /dev/ttyUSB1 will exist. Unfortunately that means you might miss some boot up messages, but after you are able to connect to the tty, you can then power cycle the board if necessary to see the boot up messages. Try both ttys, as the first one you try might be the jtag port. I have Ubuntu 18.04 on my machine. I don’t think any special package is necessary to make this work. There are the usual issues with serial ports, get the speed right, and you might try disabling hardware/software flow control.


#5

Thanks to your kind answers, I have a progression in my connecting hifive unleashed. But… still have som problem. I typed sudo screen /dev/ttyUSB0 and It works. However, It dosen’t seem like login prompt. I can’t understand what terminal says. So I added screenshot. Could you help one more time?? You are the only savior I ever met.


(Jim Wilson) #6

Did you try /dev/ttyUSB1? You might be connected to the wrong port. Otherwise, I don’t know much about screen. I use minicom. I tried using screen, and it does appear to work. I did see some gibberish on the screen when I first tried screen, but I don’t know how I managed to do that. I only see console output now.