Expansion Board details


(Wesley W. Terpstra) #21

To use an alternative config, change freedom-u-sdk/Makefile as follows:
linux_defconfig := $(confdir)/linux_framebuffer_smp # for example


(Meadhbh Hamrick) #22

Hey @AndrewBack, @bruce,

Here are the cards we’re using with the HiFive Unleashed & Unleashed Expansion board at the office. They’re obviously not the only cards that work, just a pair that worked out of the box. My co-worker David Lee acquired these boards and when asked, he said he just went to Fry’s and bought a few cards that looked decent yet reasonably inexpensive.

This is the video board: DIAMOND Radeon HD 6450 w/ 1Gb of RAM
BOARDs_000

Here’s the USB board: about as generic as you can get
BOARDs_001

And I’m willing to bet you could figure this out by looking at the boards and the sockets on the expansion board, but for completeness sake, here’s the USB board & the Video board seated in their sockets:
BOARDs_002

And here’s the output of the lspci:

And the output text is:

00:00.0 PCI bridge: Actel Device 1556
01:00.0 PCI bridge: PMC-Sierra Inc. Device 8561
02:00.0 PCI bridge: PMC-Sierra Inc. Device 8561
02:01.0 PCI bridge: PMC-Sierra Inc. Device 8561
02:02.0 PCI bridge: PMC-Sierra Inc. Device 8561
02:03.0 PCI bridge: PMC-Sierra Inc. Device 8561
03:00.0 USB controller: VIA Technologies, Inc. VL805 USB 3.0 Host Controller (rev 01)
04:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Caicos [Rade]
04:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Caicos HDMI Audio [Radeon]
06:00.0 SATA controller: Marvell Technology Group Ltd. 88SE9125 PCIe SATA 6.0 Gb/s con)

-Cheers!
-M


(Andrew Back) #23

@mhamrick, @terpstra, many thanks! HD 7450 ordered.


(ATISH KUMAR PATRA) #24

@terpstra: So we have M.2 SSD & SATA ports enabled by default as well apart from PCIe pins. Do I have to do configure something else or I just connect SATA HDD/NVME SSD and it works magically ?


(Wesley W. Terpstra) #25

If you have the kernel drivers compiled in, M.2 worked for me immediately, as did SATA.


(ATISH KUMAR PATRA) #26

Awesome. Thanks @terpstra.