Problem with FreedomStudio


(MaZhiyu) #1

Hi all,
I Configured the FreedomStudio,but I can’t debug.


(Megan A. Wachs) #2

Please ensure you have properly set up your paths to the RISC-V tools. You can find instructions in the Freedom Studio Manual, chapter https://www.sifive.com/documentation/tools/freedom-studio-manual/, “Environment Setup”, on Page 5.


Freedom Studio Beta 3
(Donnie Agema) #3

I have the following problems using FreedomStudio v1p3 under native Windows 7 (x64):

2.1.1 Windows Installation
Unzip the download to a directory on your PC by right-clicking on the zip file and selecting “Extract
All”. After unzipping the bundle, you can open Freedom Studio by clicking on FreedomStudio.exe.
Windows drivers are provided in the bundle for supported SiFive development boards. Please
install the appropriate drivers in order to debug your device. The drivers can be found in the
“FreedomStudio/SiFive/Misc” folder.

  1. I do not find the Windows drivers under the FreedomStudio/SiFive/Misc folder:

Under FreedomStudio/SiFive/Drivers I find and install the HiFive1_Driver.exe

  1. During FreedomStudio startup, automatic detection of installaion path occurs. After importing Existing Projects into Workspace I can build all projects with no errors. However, when attempting to either run or debug any project, I always get the following error:

I have tried several different USB cables and different USB ports (direct on PC, attached to USB hubs, and via Fritz!Box USB remote connection). The error is always the same. When connected via Fritz!Box USB remote the device is recognized as “FTDI Dual RS232-HS” and enumerated in Windows as “HiFive1 FTDI Driver” and “USB Serial Port (COM3)”:


When connected via direct USB port or USB hub port, the device is enumerated as 2 generic serial com ports:


I have checked the einvironment settings and cannot find any deviation from the Freedom Studio Manual.

Any help appreciated.:confused:


(Drew) #4

Hi Donnie,

  1. I do not find the Windows drivers under the FreedomStudio/SiFive/Misc folder:

Thanks Donnie. We will update the manual to reflect the proper location

  1. During FreedomStudio startup, automatic detection of installaion path occurs. After importing Existing Projects into Workspace I can build all projects with no errors. However, when attempting to either run or debug any project, I always get the following error:

When properly installed, you should have a single COM device enumerated in Device Manager with the SiFive driver enumerated as the other endpoint. I dont know what a Frtizbox is, but your screenshot for it looks correct.

The second screenshot showing 2 USB COM ports does not look correct.

Can you try installing the driver while the board is plugged into the port you intend to use on your computer?

This is a screenshot of my device manager with the driver properly installed:


(Donnie Agema) #5

Hi Drew,

Thanks for you tip.

The Fritz!Box is a DSL modem/router which has a Linux/Busybox operating system and offers remote USB device communication. I guess Linux is what identifies the driver name different from Windows.

I have been experimenting and found that if I delete the HiFive1 driver and both enumerated com ports, then connect the USB cable to a different port and reinstall the driver, I can then run and debug. I also found out that if I leave FreedomStudio before halting the run or debug session, the HiFive1 driver will become locked and must again be deleted and re-installed, after again switching the USB port, to be able to connect to a run or debug session (error: timeout while connecting to OpenOCD).

When trying to re-install WITHOUT switching the USB port, the installation starts like this:

and finishes like this (and does NOT work):


If, however, I first swith the USB port, the installation ends up looking like this (and DOES works):


(Drew) #6

Thanks for the update Donnie.

I also found out that if I leave FreedomStudio before halting the run or debug session, the HiFive1 driver will become locked and must again be deleted and re-installed, after again switching the USB port, to be able to connect to a run or debug session (error: timeout while connecting to OpenOCD).

This sounds like OpenOCD not shutting down properly instead of a driver problem. Uninstalling and reinstalling the driver is just an elaborate way of killing OpenOCD. Next time this happens, can you try opening the Window’s Task Manager to see if OpenOCD is still running? If so, try force closing.