FreedomStudio Not Responding

(Karthik) #1

Hi all,

I am new to SiFive. We have procured SiFive HiFive Rev 1 B Recently. We tried to start the software with SiFive Freedom Studio (FreedomStudio-2019-08-2-win64) for Windows (Windows 7 Professional SP1).We have imported the SiFive Welcome project for HiFive Rev1 B and built without any errors. When we tried to invoke “sifive-welcome.elf” file in debug as “1. SiFive OPENOCD Launch”, the program is getting hanged with “Not Responding” message at the top. We are forced to terminate the program through Task Manager. This happens everytime we try to do. The debugger in the configuration is GDB Setup with GDB command “gdb”.

We tried the same in Linux and there the debug window has come. But OpenOCD configuration file is missing. There is an OpenOCD config file for HiFive1 (which gave errors when run with our board) but couldnt find any for Rev 1 B.

I assume the board to be connected to PC during this time and only USB cable needs to be connected to the PC. Please help me with the same.

Thanks in advance
   Karthik R

(Jim Wilson) #2

HiFive 1 Rev B uses Segger software not OpenOCD. This is mentioned in the HiFive 1 Rev B Getting Started Guide on our web site. See the docs at

I don’t have a HiFive 1 Rev B, so I can’t help with the details.

(Karthik) #3

Dear Jim,
Thanks for the reply. I have changed the debugger to jlink and it’s working in Linux. But windows version is still hanging. I have installed windows version in another pc still the issue is there.
In Linux also every time we need to reconnect the board to pc to have a proper connection …

(Jim Wilson) #4

I don’t have a HiFive1 Rev B board as I mentioned, and don’t have access to Windows, so there is little I can do here, other than suggest getting the very latest version of the segger jlink software from Segger rather than using the one bundled with Freedom Studio, because segger does make occasional bug fixes to the software.