Changing linkerscript from to

I am trying to run hello world application on QEMU with target qemu-sifive-e31 with 1 modification: instead of using linker script, i am pointing it to The reason is I want to boot from Ram and store everything in Ram.

It can build successfully. But, the Hello world is not displayed at all.

Please help!

Hi vndao,

It appears that you’ve discovered an issue with Freedom Studio that we’ll raise up to the Development Team. With the scratchpad linker script it appears that the PC is not being set to the entry point (0x8000_0000). You can work around this in two ways:

  1. De-select the “Start target execution” option and manually set the PC to 0x8000_0000 after connecting to QEMU.
  2. Enable the “Debug in RAM” option.

These settings are available in the Startup tab of the Debug Configuration pane:

Thank you for calling this to our attention.


1 Like

Thanks a lot. It works